Compter la somme de cellules non vides SANS ...

Résolu/Fermé
JLM2856 Messages postés 478 Date d'inscription mardi 31 octobre 2006 Statut Membre Dernière intervention 10 octobre 2023 - 13 mars 2018 à 10:30
gbinforme Messages postés 14946 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 - 13 mars 2018 à 21:47
Bonjour,
Malgré de nombreuses infos je n'arrive pas à faire fonctionner une formule qui me permettrait de :
Compter le nombre de cellules non vides et sans doublons
Exemple :
Colonne A
Pierre
Paul
Marc
Paul
Sophie
Cathy
Marc
Claude

Thom
Marc
Pierre

Résultat recherché : 7

Merci d'avance pour vos retours,
A voir également:

5 réponses

Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 063
13 mars 2018 à 10:59
Bonjour,

Essaye avec cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches du clavier Ctrl, Shift et Entrée et si tu fais comme il faut la formule se placera entre ces accolades {}

=SOMME(SI(A2:A100<>"";1/NB.SI(A2:A100;A2:A100)))
3
JLM2856 Messages postés 478 Date d'inscription mardi 31 octobre 2006 Statut Membre Dernière intervention 10 octobre 2023 11
13 mars 2018 à 11:52
Formulation différente comparée à celle de gbinforme mais les 2 fonctionnent impec
Merci, bonne journée
0
gbinforme Messages postés 14946 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 680
13 mars 2018 à 10:54
Bonjour,

Avec cette formule matricielle à valider avec les touches ctrl+maj+entrée simultanées
=NB(1/FREQUENCE(SI((A1:A5000<>"");EQUIV(A1:A5000;A1:A5000;0));LIGNE(INDIRECT("1:"&LIGNES(A1:A5000)))))
1
JLM2856 Messages postés 478 Date d'inscription mardi 31 octobre 2006 Statut Membre Dernière intervention 10 octobre 2023 11
13 mars 2018 à 11:53
Formulation différente comparée à celle de mike 31 mais les 2 fonctionnent impec
Merci, bonne journée
0
Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 063
13 mars 2018 à 12:13
Re,

Si tes attentes sont satisfaites je passe le statut de la discussion en résolu
0
JLM2856 Messages postés 478 Date d'inscription mardi 31 octobre 2006 Statut Membre Dernière intervention 10 octobre 2023 11
13 mars 2018 à 13:47
ok merci
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
gbinforme Messages postés 14946 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 680
13 mars 2018 à 21:47
Bonsoir à vous 2,

je n'arrive pas à faire fonctionner une formule ...les 2 fonctionnent impec
Ce n'est pas toujours facile et tu n'as eu que 2 formules différentes mais il y en a d'autres qui peuvent fonctionner aussi car les tableurs savent faire beaucoup de calculs de différentes façons même si elles excitent parfois les neurones. ;-)

Bonne soirée à tous
0