Comparaison de cellules automatique possible ? [Résolu/Fermé]

Signaler
-
 Leusses-tucru -
Bonjour,

Dans le cadre de mon mémoire de recherche, je dois analyser sur Excel des réponses données sur des entraînements et compter les items réussis. Pour cela, je dois comparer la cellule "réponse attendue" à celle "réponse donnée". Le problème : j'ai 1800 réponses à analyser par enfant, et j'ai 15 enfants ... Je vous laisse imaginer le temps que cela va me prendre. J'aurais voulu savoir s'il y existait un moyen sur Excel pour comparer le contenu de 2 cellules automatiquement et faire mes totaux beaucoup plus rapidement ? Cela me paraît très utopique, mais vu les nombreuses possibilités avec Excel, je demande, on sait jamais !

Merci pour vos réponses,

Cordialement.

5 réponses

Messages postés
1868
Date d'inscription
lundi 16 août 2010
Statut
Contributeur
Dernière intervention
15 janvier 2021
54
Leusses-tucru, Bonjour.

Sans connaître la structure de votre feuille de calcul, il est difficile de dire que ce sera possible.

Enregistrez un exemple de votre feuille de calcul sur le site Web gratuit www.cjoint.com ou www.sendspace.com ou un autre et placez le lien de téléchargement ici.

N'oubliez pas de donner au moins un exemple concret des données et du résultat attendu.
--
Belo Horizonte, MG - Brasil.
Marcílio Lobão

Bonjour Mazzaropi,

D'abord, merci d'avoir répondu. Voici le lien créé : https://www.cjoint.com/c/HBkqMt3vn23. J'ai complètement épuré mon tableau pour ne laisser apparaître qu'une ligne correspondant à environ 5 minutes d'un entraînement et faciliter nos échanges.

Pour être précise, je voudrais comparer les réponses attendues aux réponses données, ce qui donnerait I3 vs. J3, O3 vs. P3, U3 vs. V3, AA3 vs. AB3, AG3 vs. AH3, AM3 vs. AN3, etc. Lorsque le contenu des deux cellules est identique, cela compterait 1 point. Et j'aimerais pouvoir au bout de la ligne avoir le nombre de bonnes réponses total.

J'espère avoir été assez claire,
N'hésitez pas à me demander si une information manque.

Merci d'avance !
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
550
Bonjour Leusses-tucru

Votre fichier modifié

https://www.cjoint.com/c/HBksZ6PoVrx



Bonjour Philou 10120,

Ah c'est super, merci beaucoup. Quand il y a "absent" dans deux cases côte à côte, c'est une réponse juste (réponse attendue : absent ; réponse donnée : absent).

J'ai un peu de mal à m'y retrouver dans les formules (j'ai uniquement les notions de base sur Excel), est-ce possible de me les expliquer SVP ? Car il faut par la suite que je les applique dans mes 15 véritables tableaux, avec 80 lignes chacun.

Encore merci, car je sais au moins que c'est possible !
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
550
non pour moi j'ai compris qu'il n'y avait pas de réponse donc je ne l'ai pas compté
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
550
Bonjour Leusses-tucru

=SI(ET($I3="<absent>";$J3="<absent>");"";$I3=$J3)
on contrôle si I3 et J3 contiennent absent et dans ce cas on met ""
puis on contrôle si I3 = J3 la réponse vrai = 1 faux = 0

Puis en colonne FZ, GA, GB on compte les réponses

FZ réponses bonnes = NB.SI($FA3:$FY3;VRAI)
GA réponses fausses = NB.SI($FA$3:$FY$3;FAUX)
GB sans réponse = NB.SI($FA$3:$FY$3;"")

voilà les explications
Messages postés
53095
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 janvier 2021
15 069
Salut à vous trois.

Je proposerais d'ajouter la feuille {calculs}, dans laquelle :
  • En D3 la formule serait =SOMME(E3:XBZ3)
  • En J3 la formule serait =(chassy1813!I3<>"")*(chassy1813!I3<>"<absent>")*(chassy1813!I3=chassy1813!J3) à recopier en P3, V3 etc. Pour cela, réduire la largeur des colonnes, sélectionner les colonnes J:O et tirer la poignée vers la droite jusqu'en IO (dans l'exemple fourni).

Le résultat est reporté dans la première feuille avec la formule =calculs!D3
https://www.cjoint.com/c/HBmdcT6q3bh
Messages postés
23803
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 janvier 2021
6 570
Bonjour,

en EZ3 :
=SOMMEPROD((I3:EX3=J3:EY3)*(I3:EX3<>"")*(MOD(COLONNE(I3:EX3)-9;6)=0)) 

à tirer vers le bas

Si le nombre de colonnes varient remarque que I3:EX3=J3:EY3 sont 2 plages de même taille décalées d'une colonne,
que -9 correspond à la 1ère colonne de réponse (colonne I = colonne 9),
et ;6 correspond à l'écart entre 2 réponses (toutes les 6 colonnes).

Avec *(I3:EX3<>"") une réponse vide est considérée comme fausse, à supprimer si besoin.
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci

C'est bon, j'ai réussi !! Merci à tous pour votre aide précieuse !