SI vide, Appliquer une autre formule

Résolu/Fermé
Olacasse Messages postés 12 Date d'inscription dimanche 14 mai 2017 Statut Membre Dernière intervention 18 septembre 2020 - 3 janv. 2018 à 21:59
crapoulou Messages postés 28154 Date d'inscription mercredi 28 novembre 2007 Statut Modérateur, Contributeur sécurité Dernière intervention 24 janvier 2024 - 3 janv. 2018 à 22:30
Bonjour à tous,

Dans excel, est-ce possible de faire la démarche suivante dans une seule et même formule?

Si W3*X3*Y5 = 0 effectuer la formule suivante (H3*P3)+(I3*C3)

Merci à l'avance!

Bonne journée,

3 réponses

Bonsoir,

Essaie :

SI( W3*X3*Y5=0 ;(H3*P3)+(I3*C3); W3*X3*Y5)

Ca devrait renvoyer ta deuxième formule si ton test donne 0, sinon la valeur de ton test
Rien de sûr!
Bonne chance
2
crapoulou Messages postés 28154 Date d'inscription mercredi 28 novembre 2007 Statut Modérateur, Contributeur sécurité Dernière intervention 24 janvier 2024 7 988
Modifié le 3 janv. 2018 à 22:05
Bonjour,

Oui, il te suffit d'entrer cette formule dans la case de ton choix :
=SI((W3*X3*Y5)=0;(H3*P3)+(I3*C3);<Valeur si faux>)


Remplacer <Valeur si faux> par ce que tu veux faire si W3*X3*Y5 n'est pas égal à 0.
1
Olacasse Messages postés 12 Date d'inscription dimanche 14 mai 2017 Statut Membre Dernière intervention 18 septembre 2020
3 janv. 2018 à 22:28
Bonjour,

Oui ça à marcher avec : =SI((W3*X3*Y3)=0;(H3*P3)+(I3*C3);W3*X3*Y3)

Merci de votre support!
0
crapoulou Messages postés 28154 Date d'inscription mercredi 28 novembre 2007 Statut Modérateur, Contributeur sécurité Dernière intervention 24 janvier 2024 7 988
3 janv. 2018 à 22:30
Ah très bien j'avais pas trop saisi le résultat si faux.
Je passe le sujet en Résolu.
Bonne continuation.
0
yg_be Messages postés 22475 Date d'inscription lundi 9 juin 2008 Statut Contributeur Dernière intervention 21 février 2024 1 443
3 janv. 2018 à 22:04
bonjour, peut-être:
=si(W3*X3*Y5 = 0, (H3*P3)+(I3*C3),0)
0