Somme 2 conditions dont critère mois [Résolu/Fermé]

Signaler
Messages postés
16
Date d'inscription
mardi 2 janvier 2018
Statut
Membre
Dernière intervention
4 avril 2020
-
Messages postés
23620
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 novembre 2020
-
Bonjour,

Je souhaiterai optimiser mon tableau de compte.
J'ai d'une part les mouvements lignes par lignes, et sur un autre onglet un récap mois par mois.

1er onglet = '2017'
A........................B.............................C
Date...................Catégorie...............Mouvements
lun 02 oct..........Transport................. -38,50 €
lun 02 oct..........Maison...................... -6,60 €
lun 02 oct..........Maison...................... -44,01 €
sam 04 nov.......Courses.................. -120,62 €
sam 11 nov.......Maison..................... -50,00 €
dim 10 déc........Maison..................... -12,00 €


2eme onglet
A............................B.....................C......................D
..............................sept 17...........oct 17..............nov 17
Transport
Maison............................................ ?
Courses

Je souhaiterai calculer combien j'ai dépensé pour la Maison pour le mois d'octobre. J'ai testé, entre autres, les formules suivantes :

=SOMMEPROD((MOIS('2017'!$A$2:$A$15)=10)*('2017'!$B$2:$B$17=$A3)*('2017'!$C$2:$C$26))

Et
=SOMME.SI.ENS(('2017'!C2:C10);('2017'!B2:B10);(A3);MOIS('2017'!A2:A13);MOIS(C1))

Je ne sais plus par quel bout le prendre...
Je suis sur Excel 2016 / Office 365.

https://www.cjoint.com/c/HAce5xRDNnk


Merci de vos réponses !

3 réponses

Messages postés
880
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
5 novembre 2020
182
Messages postés
16
Date d'inscription
mardi 2 janvier 2018
Statut
Membre
Dernière intervention
4 avril 2020

Merci beaucoup ! Ces formules fonctionnent bien aussi.
Messages postés
25517
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 novembre 2020
5 585
Bonjour
votre sommeprod devrait fonctionner, mais à condition que tous les champs aient la même hauteur, (voir C2:C26 ???)


vous pouvez aussi écrire en 1° item: (MOIS(

=SOMMEPROD((MOIS('2017'!$A$2:$A$15)=MOIS(B$1))*.......
pour que la formule s'ajuste à la fois au titre en A et au mois en Ligne 1, il suffira alors de la tirer sur tous le tableau.

pour info:
même remarque sur la hauteur des champs pour SOMME.SI.ENS, mais là il faut inclure les limites du mois

.........champ date ;">= date début;champ date; "<=date fin"

et donc SOMMEPROD est plus simple.

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
16
Date d'inscription
mardi 2 janvier 2018
Statut
Membre
Dernière intervention
4 avril 2020

Merci beaucoup !!! Je ne savais pas pour les hauteurs de champ ! Je suis du coup repartie sur le sommeprod qui fonctionne maintenant.
Messages postés
25517
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 novembre 2020
5 585
Pas de quoi, je passe le sujet en résolu. Mais n'oubliez pas de jeter un œil sur le post de notre ami Eric, ça peut servir (largement)
bonne route
crdlmnt
Messages postés
23620
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 novembre 2020
6 447
Bonjour,

les tableaux croisés dynamiques sont prévus pour ça, sans aucune formule.
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=109
et
http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=130
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
16
Date d'inscription
mardi 2 janvier 2018
Statut
Membre
Dernière intervention
4 avril 2020

Merci, oui j'avais pensé au TCD, je l'aurai fait si j'avais rien trouvé d'autres, mais il n'était pas nécessaire ni utile pour le reste de son utilisation.
Messages postés
23620
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 novembre 2020
6 447
Parce que tu connais mal la puissance et la simplicité des TCD.
Tout ce qui peut se faire par un TCD devrait se faire avec un TCD.
Ex obtenu en 15s : https://www.cjoint.com/c/HActggRDMlI
eric