Mise en forme conditionnelle avec NB.SI.ENS [Fermé]

Signaler
Messages postés
7
Date d'inscription
dimanche 3 décembre 2017
Statut
Membre
Dernière intervention
12 décembre 2017
-
Messages postés
13002
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 avril 2021
-
Bonjour,
Je suis en panne depuis un moment avec la fonction " =NB.SI.ENS($AN$4:$AN$16;AN$7)>0 " Je souhaite l'utiliser dans un planning (calendrier automatique) afin de faire apparaître les jours fériés en couleur en lien avec un tableau dynamique.
Je suis débutant ++ sur excel (2007) et j'ai trouvé dans un vieux topic cette formule associée à un tableau dynamique des jours fériés français.
Mais dans mon cas ça ne fonctionne pas et ça m'affiche toujours les 2 mêmes lignes (le 1er et le 4 du mois !) et comme je ne comprend pas totalement les différents éléments de la formule et leurs fonctions je n'arrive pas à comprendre ce qui ne va pas.
$AN$4:$AN$16 fait référence au champ sélectionné, mais je ne comprend pas pourquoi AN$7 qui pointe la case du 1er mai ( les différentes cellules contiennent les formules qui font apparaître les différentes dates en fonction de l'année)
Et comme j'aimerais utiliser un tableau dynamique pour les fêtes et jours férié de Genève que j'ai créé, je suis doublement embêté !

Si un âme charitable pouvait éclairer ma lanterne et me tirer de ce guêpier ! ?

Copies des documents excel concernés :
https://www.cjoint.com/c/GLhvYozqoEU
https://www.cjoint.com/c/GLhv1nulrFU

Merci




5 réponses

Messages postés
13002
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 avril 2021
2 179
Bonjour

Si tu veux de l'aide il faut poster un exemple de ton fichier (et pas une omage) sur cjoint.com, faire créer un lien le copier et revenir le coller ici

Cdlmnt
Via
Messages postés
3169
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 avril 2021
440
Bonjour,

=NB.SI.ENS($AN$4:$AN$16;AN$7)>0
il manque des arguments a ta formule
Ça devrait etre
=NB.SI($AN$4:$AN$16;AN$7)>0
Mais ça ne veut rien dire, il y aura toujours un an7 entre an4 et an16 !
Si tu veux vérifier que c'est un jour férié, c'est ce jour que tu dois comparer a ton tableau
=NB.SI($AN$4:$AN$16;b9)>0 va matcher alors que
=NB.SI($AN$4:$AN$16;b21)>0 renverra 0
et a condition que ton tableau de fériés soit dans la même feuille que le calendrier
Le mieux est de mettre le fichier, pas des images (ou il n'y a même pas les entêtes)
Messages postés
7
Date d'inscription
dimanche 3 décembre 2017
Statut
Membre
Dernière intervention
12 décembre 2017
9
Bonsoir,

Désolé pour les images à la place du fichier !
=> Lien impossible avec https://www.cjoint.com/ car limite = 15 Mo ( fichier = 50Mo)

Autre lien ci-dessous avec le ficher excel
https://wetransfer.com/downloads/d9a59ac89db54ced13e7cfbad8a3cf5c20171208203907/d5ddbef54f7d601f4213ea4bcd9bf66e20171208203907/bdb5d5
disponible 7 jours

Question supplémentaire :)) Comment inclure dans la macro "Masquer_jour" l'effacement des données contenues dans les colonnes masquées de la ligne 9 à 27 ?

Merci de vos réponses
Messages postés
13002
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 avril 2021
2 179
Bonsoir

Ton fichier avec les MFC , j'en ai mis 3 : l'une pour les fériés en France, l'autre pour ceux en Suisse et la dernière pour les fériés communs aux deux

Rajouté une ligne dans la macro pour effacer la colonne de 9 à 27

https://mon-partage.fr/f/cIUQUX4n/

Cdlmnt
Via
Messages postés
7
Date d'inscription
dimanche 3 décembre 2017
Statut
Membre
Dernière intervention
12 décembre 2017
9
Merci beaucoup pour ton aide, c'est impeccable et du coup je comprend mieux à quoi sert "B$8" dans la formule NB SI !
Et pour la macro il me manquait la bonne formulation !

Merci encore pour le temps consacré :))
Messages postés
13002
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 avril 2021
2 179
De rien

On passe en résolu

Bonne continuation