Formule pas simple [Résolu/Fermé]

Signaler
Messages postés
65
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
5 novembre 2020
-
Messages postés
65
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
5 novembre 2020
-
Bonjour,
je viens solliciter quelqu'un pour m'aider à résoudre une formule qui pour moi, n'est pas simple.
pour chaque tranche d'écart de points entre deux joueurs, existe une valeur de handicap.
je voudrais que cette formule calcule l'écart entre les points de 2 joueurs (exemple : 1110 et 1430, donc 320 points = handicap : 14) et place cette valeur dans la case correspondante.
sous-entendu que si les joueurs sont inversés (à cause du tirage au sort), la valeur doit être -14.

tableau :


merci de votre aide.

2 réponses

Messages postés
12862
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 novembre 2020
2 072
Bonjour gigipong

un exemple : https://www.cjoint.com/c/GLcqVyNN38k

Cdlmnt
Via
Messages postés
65
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
5 novembre 2020

merci beaucoup, cela répond parfaitement à mon souhait.
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 244
Bonjour,

Avec le résultat des joueurs en A1 et B1, je te propose cette formule qui devrait résoudre ton problème :
=SI(A1<B1;-1;1)*CHOISIR(EQUIV(ABS(A1-B1);{0;101;201;301;401;501};1);0;6;11;14;17;19)

Tu auras le handicap de A1 et pour avoir celui de B1 tu inverses l'opération :
=SI(B1<A1;-1;1)*CHOISIR(EQUIV(ABS(B1-A1);{0;101;201;301;401;501};1);0;6;11;14;17;19)

Messages postés
65
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
5 novembre 2020

merci de m'avoir aidé, les deux réponses me vont bien.