Formule avec datedif

[Résolu/Fermé]
Signaler
-
 vmail -
Bonjour,

je recherche une formule avec datedif afin de calculer le repeat de commande de de chaque clients

Colonne b = date d'achat
colone c = nom du client
les commande sont par ordre chronologique et donc les noms de ne suivent pas. (fichier de 46773 lignes.

merci

4 réponses

Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 700
Bonjour,

En D2, à tirer vers le bas :
=SIERREUR(DATEDIF(INDEX(C$1:C1;EQUIV(B2;B$1:B1;0));C2;"d");"")

Ou encore :
=SIERREUR(C2-INDEX(C$1:C1;EQUIV(B2;B$1:B1;0));"")
Merci de votre réponse mais aucun résultat ne s'affiche dans la cellule malgré la formule elle reste "vide"
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 700
Désolé, j'avais inversé les colonnes nom et date, ce serait plutot :
=SIERREUR(DATEDIF(INDEX(B$1:B1;EQUIV(C2;C$1:C1;0));B2;"d");"")
ou
=SIERREUR(B2-INDEX(B$1:B1;EQUIV(C2;C$1:C1;0));"")
>
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021

Merci mais le résultat est le même les cellules demeurent vide (aucun résultat ne s'affiche). j'avoue que je n'y comprends pas grand chose.
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 700 > vmail
Les dates sont-elles réellement des dates ?
Ne serait-ce pas des textes ?

En alignement standard (ni droite, ni centrer, ni gauche, ni justifié), sont-elles alignées à droite ou à gauche ?
>
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021

les dates sont au format date et centré
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 700
Re,

Désolé mais la formule précédente n'est pas sufisnte.

Voici un exemple avec des calculs intermédiaires:
https://mon-partage.fr/f/NIZamAgh/
super cela fonctionne merci