Concatener à conditions

Résolu/Fermé
Ichou45 Messages postés 7 Date d'inscription mercredi 28 décembre 2016 Statut Membre Dernière intervention 30 novembre 2017 - 29 nov. 2017 à 19:06
 Ichou45 - 5 déc. 2017 à 15:02
Bonsoir,

J'ai une feuille avec 2 colonnes :

A = les numeros de bon de livraison.
B = les articles livrés par bon de livraison

Pour y voir plus clair ci joint un exemple :

https://www.cjoint.com/c/GKDrY3RyBfw

En C je devais avoir concatener tout les enregistrements de la colonne B selon le numéro du BL.

Merci d'avance.

5 réponses

Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033
Modifié le 29 nov. 2017 à 19:25
Bonsoir,

on peut le faire avec un code VBA si tu as quelques notions de VBA


A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
0
Ichou45 Messages postés 7 Date d'inscription mercredi 28 décembre 2016 Statut Membre Dernière intervention 30 novembre 2017
29 nov. 2017 à 19:28
Non merci Mike-31 sans vba si possible.
0
Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033
Modifié le 29 nov. 2017 à 19:48
Re,

regarde avec ce genre de formule sur la première ligne exemple en F2

=SI(B2<>"";F1&B2;"")

ensuite on verra de masquer les valeurs inutiles
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
0
Ichou45 Messages postés 7 Date d'inscription mercredi 28 décembre 2016 Statut Membre Dernière intervention 30 novembre 2017
30 nov. 2017 à 14:27
Bonjour,
J'ai essayé mais ca ne fusionne que 2 cellules a la fois, un bl ca peut contenir min 1 article max 25 articles.

Je teste actuellement =si(et(a1<>"";b1<>"";a2="");b1&" / "&b2;""))
Reste a ajouter une formule a la précédente dans le cas ou a1<>"" et a2="" et b1<>"" et b2<>"" pour fusionner les 3 cellules suivante, la dernière etant vide ca va renvoyer une erreur....

Des idées ?
0
Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033
30 nov. 2017 à 14:53
Re,

tu as certainement mal saisi la formule
regarde ce fichier tu as deux type d'affichage soit la concaténation en fin de groupe soit en début
ajoute des valeurs jusqu'à la ligne 40
https://www.cjoint.com/c/GKEn1lTtGoj
0
Ichou45 Messages postés 7 Date d'inscription mercredi 28 décembre 2016 Statut Membre Dernière intervention 30 novembre 2017
30 nov. 2017 à 22:49
Re,

Ça marche tres bien, juste un dernier souci de separateur d'articles soit par " / " ou " ; " je fais comment ?

Merci beaucoup pour ta solution, c'est top.
0
Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033
30 nov. 2017 à 23:27
Re,

sur mon fichier en C2 colle cette formule et incrémente la vers le bas
=SI(B2<>"";C1&B2&"/";"")

ou en D10 cette formule et incrémente la vers le haut
=SI(B10<>"";B10&"/"&D11;"")

en retour donne moi la formule retenue on supprimera la fraction de fin
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Merci pour ta précieuse aide Mike-31. Probleme resolu en entier. Formule retenue celle de la colonne B.

Merci.
0