Ne pas prendre en compte les lignes filtrées. [Résolu/Fermé]

Signaler
Messages postés
98
Date d'inscription
lundi 2 octobre 2017
Statut
Membre
Dernière intervention
1 juillet 2019
-
Messages postés
17373
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 juin 2021
-
Bonjour,

Dans un fichier Excel,

J'ai un segment qui filtre les données pour un graphique.
Les lignes non visibles sont prises en comptes hors je ne le souhaite pas.
J'ai essayé avec la formule sous.total mais aucun code ne me remonte la bonne valeur, il me fait le total des lignes visibles dans le filtres mais ne me remonte la données en face de la cellule Janvier.

Je fais référence à un mois puis à un libellé pour prendre la donnée numérique en face.
D4 correspond au libellé texte, A5 correspond au mois et B21:B200000 ou se trouvent les données numériques.

=SOMMEPROD(($A$21:$A$200000=$D$4)*($A$5=$C$21:$C$200000))*SOUS.TOTAL(109;($B$21:$B$200000))

3 réponses

Messages postés
17373
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 juin 2021
4 642
Bonjour,
Ta formule ne veut rien dire, explique simplement ce que tu veux faire après avoir filtré ton tableau
la somme de quelle colonne !
et en fonction du critère de quelle colonne !

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
98
Date d'inscription
lundi 2 octobre 2017
Statut
Membre
Dernière intervention
1 juillet 2019

Bonjour Mike,

En faite j'ai un tableau avec 4 colonnes en connexion d'une base access.

La colonne A : plusieurs libellés différents en format texte tel que TG2 cedex, 2S cedex....

La colonne B : le nombre de plis en format numérique

La colonne C : le mois de production

La colonne D : l'année



Je reprends les données sur un tableau ordinaires juste collé au dessus avec sommeprod pour les classer par mois et par libellé pour alimenter un graphique au quel j'ai mis un segment sur les libellés.

Je cherche, en sélectionnant par exemple le libellé TG2 cedex, que le graphique alimenté par le tableau me remonte la donnée en face du mois correspondant dans mes critères.

Avec sous.total il me remonte le total de tous les mois qui sont dans le filtres et donc ne prend pas en compte mes critères de mois.

pour expliquer mieux, j'ai tenté de mettre une capture en ligne de mon fichier excel mais je n'y arrive pas, problème de format je pense.
Messages postés
17373
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 juin 2021
4 642
Re,

Si j'ai bien compris tes explications
=SOMMEPROD((SOUS.TOTAL(109;DECALER($B$21;LIGNE($21:$200000)-21; )))*($A$21:$A$200000=$D$4)*($C$21:$C$200000=$A$5))

ci ce n'est pas ça joint un exemple de fichier pas une capture écran
Messages postés
98
Date d'inscription
lundi 2 octobre 2017
Statut
Membre
Dernière intervention
1 juillet 2019

C'est énorme Mike, ça fonctionne ! ! chapeau et sans avoir joint le fichier en exemple.

Un énorme merci Mike !
Messages postés
17373
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 juin 2021
4 642
Re,

Si tes attentes sont satisfaites passe le statut de la discussion en résolu