Trouver une fonction sur excel de la somme avec critères [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 27 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2017
-
Messages postés
3
Date d'inscription
vendredi 27 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2017
-
bsr, g une ligne sur excel dont je dois faire la somme de ses cellules , sachant qu il a des lettres avec des nombres , chaque lettres corresponde a un chiffre bien déterminé
exemple , A+P+F+C+3+A+P+p+5 ; nb : A et F égale à 0 et P et F égale à 7
Merci d'avance

1 réponse

Messages postés
3100
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
25 février 2021
861
Bonsoir,

J'ai reproduis la suite lettres/chiffres ci-dessus en A2>I2

Dans les explications F c'est 0 ou 7 ??
Le premier F est remplacé par le C à inverser si c'est le cas

Formule : =SOMME(NB.SI(A2:I2;"A")*0;NB.SI(A2:I2;"C")*0;NB.SI(A2:I2;"F")*7;NB.SI(A2:I2;"P")*7;A2:I2)

Cordialement
Messages postés
3
Date d'inscription
vendredi 27 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2017

bonsoir PapyLuc51 , c est tres gentil a vous ,pour le F c est 0 , mais j ai bien compris , j ai inversé , et c est bon , merci beaucoup , excellente soirée
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
6 668
Bonjour,

Bah, on peut laisser tomber les = 0 ;-)
Il n'y a que les P et F à compter, plus les nombres
=(NB.SI(A2:I2;"F")+NB.SI(A2:I2;"P"))*7+somme(A2:I2)

eric
Messages postés
3
Date d'inscription
vendredi 27 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2017
>
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021

bonsoir eriiic , oui vous avez raison ,,, merci beaucoup