Formule SI et condition "plus petit" et "plus grand" [Résolu/Fermé]

Signaler
-
 Utilisateur anonyme -
Bonjour,

Je cherche une formule qui calculerait un pourcentage selon l'âge de la personne.

Je m'explique :

Dans mon tableau, nous avons l'année en cours(A1), le nom de la personne (A3) l'année de naissance(B3) de la personne, un salaire brut(C3) et une cellule à calculer en fonction de l'âge (D3).

Plus bas, j'ai un second tableau avec les données, exemple :


(A6) De 20 à 29 ans | (B6) 2%
(A7) De 30 à 39 ans | (B7) 3%
(A8) De 40 à 49 ans | (B8) 4%


J'aimerais que la formule calcule A1-B3 pour obtenir l'âge, puis qu'en fonction de l'âge on est le bon taux utilisé, donc SI A1-B3 = >20<29 alors calcule-moi B6 * C3" mais si A1-B3 = >30<29 alors calcule-moi B7 * C3" etc...

En bref, si âge (A1-B3) est plus grand que 20 mais plus petit que 29 alors calcule B6*C3 mais si âge est plus grand que 30 mais plus petit que 39 alors calcule B7 * C3 et ainsi de suite.

J'ai essayé de l'écrire avec la formule Si, le problème est que la valeur si faux serait de passer à la formule suivante (tranche d'âge suivante) et je ne sais pas comment l'inscrire.

Vous voyez l'idée ? Merci de votre aide :)

2 réponses

Messages postés
25385
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 octobre 2020
5 532
Bonjour
simplement en plaçant les conditions dans l'ordre croissant

=C3*SI(DATEDIF(B3;$A$1;"y")<=29;$B$6;SI(DATEDIF(B3;$A$1;"y")<=39;$B$7;$B$8))

DATEDIF donne le nombre d'années complètes entre deux dates


mais par contre, vous ne dites pas ce que vous voulez éventuellement pour les + de 49 ans et les moins de 20?

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Utilisateur anonyme
Bonjour, la proposition de fabien25000 correspond totalement à ce que je cherchais, dans ma demande je n'ai mentionné que 3 tranches d'âge mais la finalité va couvrir bien plus, ce n'est que pour l'exemple ;)

Merci beaucoup pour votre aide tout de même et belle journée :)
Messages postés
591
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
19 juin 2020
49
Bonjour,

est-ce cela que tu cherches :

=SI(A1-B3>=40;B8*C3;SI(A1-B3>=30;B7*C3;SI(A1-B3>=20;B6*C3)))
Utilisateur anonyme
Ouiiiiiiiiiii ça marche parfaitement merci beaucoup, à force de chercher, j'allais trop loin ;) Merci merci merci ! :) Bonne journée !