Formule pour mettre des cellules verticales dans une ligne

Résolu/Fermé
Signaler
-
 Silana -
Bonjour,

Je suis en train de réaliser un tableau que je souhaiterais automatiser mais je ne parviens pas à trouver la formule adaptée :

Mes données sont dans le Feuillet 1 en colonne B sur une cinquantaine de lignes environ.

Je réalise mon tableau dans le Feuillet 2 et souhaite répartir les données de la colonne B du Feuillet 1 dans la ligne 1 de mon feuillet 2 (en horizontal donc), et les inclure dans la formule suivante :

SI('Feuillet1'!B1<0;'Feuillet1'!B1;0)

Ainsi, par exemple dans mon Feuillet 2, je voudrais aboutir au résultat suivant :

Cellule A1 : SI('Feuillet1'!B1<0;'Feuillet1'!B1;0)
Cellule B1 : SI('Feuillet1'!B2<0;'Feuillet1'!B2;0)
Cellule C1: SI('Feuillet1'!B3<0;'Feuillet1'!B3;0)
etc...

Sauf qu'évidemment, lorsque j'étire ma formule ça me donne les données horizontales de mon Feuillet 1 et non verticales.

Qqu aurait-il une formule que je pourrais intégrer dans ma formule SI afin que ce soit les données verticales du feuillet 1 qui se reportent de manière horizontale sur mon feuillet 2 ?

Merci beaucoup !!

3 réponses

Messages postés
2231
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
21 novembre 2021
333
Bonjour,
En A1
=SI(INDIRECT("'Feuillet1'!B" & COLONNE())<0;INDIRECT("'Feuillet1'!B" & COLONNE());0)
à tirer sur la droite
Cdlt
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 127
Bonjour
juste pour raccourcir un peu:

=MAX(0;INDIRECT("'feuillet1'!B"&COLONNE()))

ne fonctionne pour ressortir la ligne 1 que sur la colonne A
si la formule ne se trouve pas dans la 1° colonne pour ressortir la 1° ligne, écrire:

=MAX(0;INDIRECT("'feuillet1'!B"&COLONNE(A$1)))

qui renverra la ligne 1 de feuillet1 quelque soit sa position dans la page, en incrémentant la ligne vers la droite



crdlmnt


Messages postés
2231
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
21 novembre 2021
333
Bonjour Vaucluse
Evidemment, c'est plus chic.
Juste une petite remarque par rapport à la question posée, "MIN" ne semble-t-il pas plus approprié que "MAX", vu que l'on cherche les valeurs négatives?
Cdlt
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 127
Exact, tout à fait Frenchie,
Ce ne sera peut être pas plus chic, mais ce sera plus juste!!!
quant à dire plus chic, non, c'est simplement pour éviter de doubler les codes INDIRECT que j'ai fait cette proposition en surenchère sur la tienne qui était tout à fait correcte
Bien cordialement
Merci beaucoup pour vos réponses et votre aide !