Somme de plusieurs colonnes variables

Résolu/Fermé
Signaler
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
-
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
-
Bonjour

je dois réaliser des sommes d'éléments situés sur des colonnes différentes pour regrouper en catégorie ( je ne peux pas déplacer les colonnes pas la même vision).

Chaque en tête de colonne contient un code.

Je souhaite réaliser la somme de la nature 1 pour la fonction A, pour la fonction B ...
puis nature 2.

Chaque fonction contient un ensemble de code. ( Petit tableau)

Je veux donc interroger la ligne 1, si le code de la colonne appartient à la selection du tableau (Fonction 1) l'integrer dans la somme....

J'ai mis un exemple de fichier pour tenter d'expliquer.

Quelle formule excel puis je utiliser pour realiser les sommes ?

Par avance merci de vos reponses.

lien du fichier

http://www.cjoint.com/c/GICmGKxylcK

2 réponses

Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022
2 327
Bonjour,

En W2 :
=SOMME.SI($B$1:$U$1;"<200";B2:U2)

En X2
=SOMME.SI.ENS(B2:U2;$B$1:$U$1;"<300";$B$1:$U$1;">=200")

En Y2 :
=SOMME.SI.ENS(B2:U2;$B$1:$U$1;"<400";$B$1:$U$1;">=300")

En Z2 :
=SOMME.SI($B$1:$U$1;">=400";B2:U2)

Etirer ensuite les formules vers le bas

Cdlmnt
Via
0
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
1
Bonjour

merci de cette reponse mais les codes du fichier sont juste des exemples.
Dans le vrai tableau il y a des codes avec des lettres également.

Désolé j'aurais du précisé
0
Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022
2 327 >
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021

OK

Alors envoie un fichier avec les bons codes qu'on voit s'il y a une logique exploitable
0
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
1 >
Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022

http://www.cjoint.com/c/GICpWjwTKCK

j'ai mis un echantillon mais il n y a pas de logique

en tout cas je pense
0
Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022
2 327
Bon alors en passant par une fonction personnalisée :
https://www.cjoint.com/
Explications dans le fichier

Cdlmnt
Via
0
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
1
Bonsoir

je n'arrive pas à accéder au fichier
0
Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022
2 327 >
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021

et ici :
https://mon-partage.fr/f/u9P3Oghm/
0
Messages postés
348
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
15 avril 2021
1 >
Messages postés
13350
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022

Bonsoir

super c'est parfait !

je chercher une solution sans vba mais ça me va très bien.

Un grand merci
0