Formule = renvoi valeur

Fermé
Ryujin94 - 31 août 2017 à 12:12
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
- 31 août 2017 à 19:20
Bonjour,

Voila je ne sais pas trop comment expliquer le problème donc je vais plutôt vous expliquez ce que je veux.

J'ai une colonne de TOTAL avec les lignes a gauche par mois , juillet,août,septembre....

Chaque cellule du TOTAL renvoi à la somme d'un autre tableau sur un autre onglet donc jusque-la aucun problème.

Le hic c'est que quand je veut dérouler ma formule du total de juillet pour le descendre jusqu'a décembre les totaux ne correspondent plus car dans l'autre onglet les totaux ne sont pas sur la même ligne mais à 5 lignes d'intervalles à chaque fois.

Y'a t-il un moyen de rendre cela automatique sans s'amuser a aller chercher chaque total avec la fonction =? car j'ai un fichier plutôt volumineux.



2 réponses

via55
Messages postés
13593
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 mai 2022
2 400
31 août 2017 à 14:02
Bonjour

En utilisant des références absolues (signes $) il ne devrait pas y avoir de problème
Pour être plus calir et avoir une aide poste un exemple de ton fichier su cjoint.com, fais créer un lien, copies le et reviens le coller ici

Cdlmnt
Via
0
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 750
Modifié le 31 août 2017 à 19:22
Bonjour,

Pour récupérer, sur des lignes consécutives, la somme des valeurs situées toutes le 5 lignes sur un autre onglet, tu peux utiliser une formule du type :
=SOMME(DECALER(Feuil2!$B$4:$E$4;(LIGNES($1:1)-1)*5;0))
en remplaçant uniquement Feuil2!$B$4:$E$4 par l'emplacement des premières cellules de l'autre onglet (attention à conserver les $)

Cordialement
Patrice
0