Tableau en haut de la page [Résolu/Fermé]

Signaler
Messages postés
62
Date d'inscription
mercredi 2 décembre 2015
Statut
Membre
Dernière intervention
17 mai 2020
-
Messages postés
62
Date d'inscription
mercredi 2 décembre 2015
Statut
Membre
Dernière intervention
17 mai 2020
-
Bonjour,

je voudrais créer un conteneur dans une page où il y aura du texte et un tableau.

Mon problème est que je n'arrive pas à coller ce conteneur en haut de la page. J'ai une bande d'une quinzaine de pixels entre le haut de la page et le haut du conteneur où l'image de fond apparaît.
Après avoir pas mal fouillé le net la solution semble être ;
body{margin:0;padding:0;}
ce qui ne fonctionne pas ici, voir la css ci-dessous.

Le conteneur est bien collé au bas de la page, sans bande d'image de fond.
Si je mets la "width" du conteneur à 100%, il est bien collé aux bords gauche et droite de la feuille.

Comment faire puisque la solution habituellement appliquée ne fonctionne pas?

La CSS:
body {
background-image: url("seasideT.jpg");
background-attachment:fixed;
background-repeat:no-repeat;
background-position:top,center;
background-size:100% 100%;
margin:0;
padding:0;
}

.contain {
width:800px;
padding:0 15px 20px 15px;
background-color: rgba(255,255,255,0.7);
margin-left:auto;
margin-right:auto;
text-align:justify;
vertical-align:top;
}


Le HTML :

<body>
<div class="contain">
texte
<br><br>
<table>
<tr>
<td>
Lorem ipsum dolor sit amet, consectetur adipiscing elit.
</td>
</tr>
</table>
</div>

</body>


Par avance
Merci
Fifi

3 réponses

Messages postés
2379
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
10 mars 2020
429
Salut,

De mon coté le div contain est bien collé en haut de la page avec ton code :
https://jsfiddle.net/yntzyjua/

Tu peux éventuellement essayer de supprimer les marges sur la balise html :
html { margin: 0; padding: 0; }


Bonne journée,
Messages postés
62
Date d'inscription
mercredi 2 décembre 2015
Statut
Membre
Dernière intervention
17 mai 2020

Bonjour Pitet,
et merci pour le coup de main.
J'ai essayé de supprimer les marges html, mais rien n'y fait. Ce qui me pète quand même c'est que le problème semble n'exister qu'en haut. Sur les côtés et en bas tout va bien. La marge du haut aurait-elle un statu différent des autres ??
Fifi
Messages postés
2379
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
10 mars 2020
429
Non la marge du haut n'a rien de différent des autres marges.
Tu as peut être un caractère invisible/indésirable au début de ton fichier qui cause se décalage. As tu la possibilité d'uploader ton fichier complet afin qu'on puisse tester dans avec la même source ?
Messages postés
62
Date d'inscription
mercredi 2 décembre 2015
Statut
Membre
Dernière intervention
17 mai 2020

Argh!!!!

je hais les caractères indésirables ;-)
J'avais en effet un point qui traînait dans le <head> et qui mettait la zone.

Merci encore, ça commençait à me rendre nerveux,
Fifi