Qui me trouve la formule

Résolu/Fermé
Signaler
Messages postés
7
Date d'inscription
dimanche 11 juin 2017
Statut
Membre
Dernière intervention
16 juin 2017
-
Messages postés
7
Date d'inscription
dimanche 11 juin 2017
Statut
Membre
Dernière intervention
16 juin 2017
-
Bonjour à tous,


je fais appelle encore appelle à vous car je n'arrive pas imbriquer
2 fonctions dans excel

je m'explique dans la feuille de calcul j'ai deux onglets
la premiere etant celle ou je veux appliquer la formule le deuxieme onglet se trouve les valeurs que je cherche (le stock en F)

ma premier formule est de chercher 4 chiffres dans une suite de nombre et d'utiliser le resultat dans une fonction rechercheV
j'arrive à le faire sur deux formules mais pas avec une seul

la premiere formule est =CNUM(STXT(B3;8;4)) qui sur le deuxieme onglet
la deuxieme formule est =RECHERCHEV(A2;'stock '!$A$1:$G$17;6;FAUX) par exemple

en plus clair
je dois trouver en onglet 2 le gencod de A2 soit 2233 pour trouver le stock en onglet 1

je joins le fichier au cas ou

https://www.cjoint.com/c/GFmtJMRWPT2

par avance merci

5 réponses

Messages postés
3365
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2021
485
Bonjour,

Je crois que ce n"est pas le bon fichier !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
dimanche 11 juin 2017
Statut
Membre
Dernière intervention
16 juin 2017

ah oui mince

je reposte le lien

https://www.cjoint.com/c/GFnft0P1pZ2

j' en pprofite pour vous dire que recherchev n'est pas la bonne formule mais index equiv serait mieux je pense
Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 décembre 2021
3 251
bonjour

avec une colonne intermédiaire (évite un casse t^te !!!)

le classeur en retour
https://mon-partage.fr/f/xzPbgaMg/
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
dimanche 11 juin 2017
Statut
Membre
Dernière intervention
16 juin 2017

Merci Michel

c'est ce que je veux faire mais malheureusment c'est deja ce que j'ai fait.
seulement je cherche a faire la meme chose en une seule formule car le tableau de stok
est un tableau sur lequel je ne peux agir et il est renouvellé continuellement
Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 décembre 2021
3 251
Bonjour
bonjour djidji, excuse l'incruste

pourquoi appeler "stock" dans ta recherche alors la référence complète du produit se trouve dans "stock" et le tarif dans la feuille "tarif brut")

=RECHERCHEV(CNUM(DROITE(B3;4));'TARIF BRUT '!A$2:C$16;3;0)
Messages postés
3365
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2021
485
Bonjour,

Pas de problèmes !
Si ce n'est pas moi, c'est donc mon frère (en excel) !!

Crdmt
Messages postés
7
Date d'inscription
dimanche 11 juin 2017
Statut
Membre
Dernière intervention
16 juin 2017

la formule ne fonctionne pas sur le fichier

je me suis peut etre mal exprimer

onglet 1 (tarif brut) a un gencode court ici 2233 (quatre derniers chiffres )
je dois trouver le stock qui est en onglet 2 (stock) avec un gencode long ici13473572233 ( dout la recherche de txt et un conversion en nom (cnum)

sur mon premier onglet en D2 je dois trouver le resultat de l'onglet stock en f3

merci de aide je rame
Messages postés
3365
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2021
485
Bonjour,

Un essai :

https://www.cjoint.com/c/GFoqJj7HFQ2

Crdmt
Messages postés
7
Date d'inscription
dimanche 11 juin 2017
Statut
Membre
Dernière intervention
16 juin 2017

super
merci
genial
impec

Resolu donc