Formule excel indirect index equiv

Résolu/Fermé
Guilouxx Messages postés 7 Date d'inscription dimanche 11 juin 2017 Statut Membre Dernière intervention 16 juin 2017 - 11 juin 2017 à 19:10
Guilouxx Messages postés 7 Date d'inscription dimanche 11 juin 2017 Statut Membre Dernière intervention 16 juin 2017 - 12 juin 2017 à 14:26
Bonjoir,
(melange entre bonjour et bonsoir vu que je ne sais pas quelle heure vous allez me lire)

Donc j'ai un fichier excel avec une formule que je ne sais pas faire je compte donc sur votre bonté pour m'aider car c'est un peu compliqué

je m'explique :

colonne A les gencod
colonne B le libellé
colonne C Prix brut
colonne D les tarifs (avec menu deroulant)
colonne E les tarifs (avec menu deroulant)
colonne F les tarifs...etc (avec menu deroulant)

onglet tarif brut
onglet tarif 1
onglet tarif 2
onglet tarif 3 etc

je souhaite trouver la ou les formules qui me trouve la formule du produit aillant le meme gencod dans les tarif 1 ou 2 ou ..etc en fonction du tarif avec le menu deroulant selectionné

je vous joins mon fichier excel vous allez mieux me comprendre

https://www.cjoint.com/c/GFlrkf6Q1S2


par avance merci

1 réponse

eriiic Messages postés 24452 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 30 septembre 2022 7 135
11 juin 2017 à 20:01
Bonjour,

qui me trouve la formule du produit
La formule ? Le libellé non ?

Pas sûr d'avoir bien compris, ça me parait trop simple. En D2 :
=SIERREUR(RECHERCHEV($A2;INDIRECT("'"&D$1&"'!$A:$C");2;FAUX);"") 

à tirer vers la droite et vers le bas
0
Guilouxx Messages postés 7 Date d'inscription dimanche 11 juin 2017 Statut Membre Dernière intervention 16 juin 2017
12 juin 2017 à 14:26
Bonjour Eriiic

si si c'est cela que je cherchais mais j'imbriquais recherchev dans indirect et pas le contraire
merci beaucoup je galerais depuis des jours
0