Excel : insérer résultat fonction matricielle dans autre formule [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
mardi 30 mai 2017
Statut
Membre
Dernière intervention
5 juin 2017
-
Messages postés
53123
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
-
Bonjour,


Cela fait déjà une heure que je cherche ne vain pour insérer le résultat de ma fonction matricielle dans une formule.

Je m'explique :

Ma fonction matricielle {MAX(SI(ESTVIDE($D$11:$D$500);0;LIGNE($D$11:$D$500)))} me permet de trouver le numéro de la dernière ligne nom rempli.
J'aimerai insérer ce numéro dans ma formule à la place de 56 : SOMMEPROD((MOIS($A$11:$A$56)=MOIS(C$8))*1*($D$11:$D$56=$A11))

Sauriez-vous comment faire svp ??

Je vous remercie d'avance !

Fred

2 réponses

Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
828
Bonjour,

J'essaierais avec soit la fonction DECALER() soit INDIRECT().

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
13
Date d'inscription
mardi 30 mai 2017
Statut
Membre
Dernière intervention
5 juin 2017

Merci pour ta réponse JvDo. Je vais essayer avec les fonctions DECALER() et INDIRECT().

En réalité ma question est simple, au lieu d'écrire A56, j'aimerai écrire A{MAX(SI(ESTVIDE($D$11:$D$500);0;LIGNE($D$11:$D$500)))}

{MAX(SI(ESTVIDE($D$11:$D$500);0;LIGNE($D$11:$D$500)))} me renvoie 56
Messages postés
13
Date d'inscription
mardi 30 mai 2017
Statut
Membre
Dernière intervention
5 juin 2017

j'ai essayé avec "&" mais ça ne fonctionne pas
Messages postés
53123
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
15 102
Bonjour.

Difficile de mélanger une formule matricielle et une formule normale ...
Fais ton calcul matriciel dans la cellule X1 et écris ta formule
=SOMMEPROD((MOIS($A$11:INDIRECT($A&$"X1")=MOIS(C$8))*1*($D$11:INDIRECT($D&$"X1")=$A11))
Il faudra essayer et peut-être corriger ma proposition, que je n'ai pas testée moi-même ...
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
13
Date d'inscription
mardi 30 mai 2017
Statut
Membre
Dernière intervention
5 juin 2017

Bonjour Raymond,

Oui effectivement, ta formule fonctionne parfaitement en déplacant le "&" après le "$". Merci beaucoup pour ton aide !

Bon week-end !
Messages postés
53123
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
15 102 >
Messages postés
13
Date d'inscription
mardi 30 mai 2017
Statut
Membre
Dernière intervention
5 juin 2017

OK, et bravo.