Addition d'heures en fonction du mois et de l'année.... [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
dimanche 21 mai 2017
Statut
Membre
Dernière intervention
21 mai 2017
-
Messages postés
2
Date d'inscription
dimanche 21 mai 2017
Statut
Membre
Dernière intervention
21 mai 2017
-
Bonjour,

j'essaye sans succès jusque là à additionner des heures sur Excel....
Mon tableau:

a b c d ......
date heures heures heures ......

L'idée étant d'additionner les heures (a+b+c) effectuées au mois de mai 2016 et au mois de mai 2017 comme au mois 2015...
Mais aussi d'additionner (a+b) et aussi (b+c) ou encore (b+d).... en fonction du mois.

jj/mm/aaaa pour le format de la date et 00:00:00 pour le format de l'heure.

j'ai essayé SOMMEPROD / SOMME.SI / SOMME.SI.ENS. J'arrive à le faire avec SOMME.SI.ENS comme cela:

=SOMME.SI.EN(H2905:H3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.ENS(I2905:I3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.ENS(J2905:J3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(K2905:K3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.ENS(L2905:L3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(M2905:M3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(N2905:N3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)*SOMME.SI.EN(O2905:O3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.ENS(P2905:P3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(Q2905:Q3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(R2905:R3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(S2905:S3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.ENS(T2905:T3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)+SOMME.SI.EN(U2905:U3520;A2905:A3520;">="&A3491;A2905:A3520;"<="&A3520)

mais j'aimerais le faire sur une plage de donnée en non colonne par colonne (comme au dessus ou il s'agit en faite de l'addition des colonne de H à U) et en fonction d'une date pas d'une valeur de cellule, dans l'exemple A3491 et A3520 sont les bornes mais chaque nouveau mois m'oblige à modifier manuellement toute les SOMME.SI.ENS

Je cherche à "raffiner" la formule pour éviter de passer à chaque fin de mois de modifier un à un les SOMME.SI.EN (le tableau fait 20 colonnes de large et 4000 lignes du coup dans les conditions de SOMME.SI.ENS la formule est monstrueuse et très vite difficile à adapter en fonction de changement de cellule, critères et autres....)

Pour le moment je n'utilise pas cette formule... je fais manuellement en utilisant une selection manuelle avec le curseur du type "=SOMME(Feuil1!L2740:O2855)"

Je ne sais pas utiliser la macros... et toute bonne idée sont écoutées!!

Merci pour vos réponses,
V.


4 réponses

Messages postés
17300
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 janvier 2021
4 432
Bonjour,

Je pense que tes dates sont colonne A
essaye comme cela si le critère mois est en format numérique en F1 et l'année en G1
formule jusqu'a la ligne 20 à adapter bien sur
=SOMMEPROD((MOIS($A$1:$A$20)=F1)*(ANNEE($A$1:$A$20)=G1)*($B$1:$D$20))

ou encore comme cela
=SOMMEPROD((MOIS($A$1:$A$20)=F1)*(ANNEE($A$1:$A$20)=G1)*($B$1:$B$20+$C$1:$C$20+$D$1:$D$20))

et si le critère en cellule dans mon exemple F1 est saisi en toute lettre
=SOMMEPROD((ANNEE($A$1:$A$20)=G1)*(MOIS($A$1:$A$20)=MOIS(1&F1))*($B$1:$D$20))
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Super! Merci beaucoup!!!

V.
Messages postés
17300
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 janvier 2021
4 432
Re,

si tes attentes sont satisfaites, je passe le statut de la discussion en résolu
Messages postés
2
Date d'inscription
dimanche 21 mai 2017
Statut
Membre
Dernière intervention
21 mai 2017

C'est parfait oui, j'en profite encore pour poser une dernière question sur le compte d'heure.

Dans le même tableau je fais la somme d'heures effectuées dans les 6 derniers mois, 3 derniers mois et derniers mois.... (mois glissant) en utilisant cette formule:

=SOMME.SI(A4:A3524;">="&AUJOURDHUI()-364;M4:M3524)

Le problème encore ici est que cette formule ne marche pas sur une plage de donnée (colonne H à colonne U) mais sur une colonne unique.... et j'aimerais pouvoir le faire sur une plage entière.

Je ne trouve pas vraiment de solutions dans les discussions précédentes... et je suis preneur d'une bonne solution.

V.