Utiliser autre formule si cellule vide

[Résolu/Fermé]
Signaler
Messages postés
663
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
24 septembre 2021
-
Messages postés
663
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
24 septembre 2021
-
Bonsoir la communauté :)

J'utilise un document excel pour noter mes heures de travail. Le changement d'année se fait bien, mais février me pose des problèmes (vous devinez pourquoi).
Je calcule, en plus de tout le reste, le nombre d'heures mensuelle, et forcément, mes formules sont tirées jusqu'au 29, au cas où.
Je voudrais, dans le cas où il n'y a pas de 29 février, que la formule s’intéresse à la formule du dessus.
Quelque chose comme : "Formule (Sauf Si B36 est vide Alors utiliser la formule B35)"
Le problème c'est que pour déterminer le dernier jour de la semaine et calculer les heures de celle-ci, j'utilise une formule longue, je crains qu'Excel trouve "trop d'arguments" :/
Peux-être existe-t-il une autre solution, autre que VBA dans un premier temps ?
Voici le fichier en question : https://www.cjoint.com/c/GEsrKifQffP

Merci d'avance pour votre aide !


2 réponses

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 063
Bonsoir
voyez si ce modèle (feuille Février seulement)
peut correspondre à vos attentes
https://mon-partage.fr/f/CbddWRum/
les zones grisées afficheront les dates selon la longueur du mois, et ce type est donc valable pour tous les mois (28,29,30,31)
j'ai aussi modifié les cellule dates en B qui se référent maintenant à la date inscrite en titre du mois et j'ai supprimé le code SOMME inutile dans les additions

crdlmnt

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
663
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
24 septembre 2021
51
Avec plus d'un mois de retard : merci ! :)
Messages postés
126
Date d'inscription
jeudi 9 décembre 2010
Statut
Membre
Dernière intervention
21 février 2019
21
Bonsoir,

Si j'ai bien compris, alors en "N36":
=SI($A36="";0;SI(OU(JOURSEM($A36;2)=7;$A36=DATE(ANNEE($A36);MOIS($A36)+1;);0);SOMME(K$8:K36)-SOMME(N$7:N35);0))

Cordialement.
Messages postés
663
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
24 septembre 2021
51
Merci pour cette réponse !
Ca fonctionne, mais je n'ai plus le calcul; certainement parce-que la cellule A36 n'est pas vide (elle contient une formule) :/
En fait, je pense que les formules de N35 et N36 doivent être modifiées. En effet, lorsque février ne compte que 28 jours, je n'ai pas la somme de la semaine en N35.
Dans le cas d'une année bissextile, la somme devrait s'afficher à N36, et plus dans N35.

Je ne sais pas si c'est clair mon affaire... :/

Merci encore pour l'aide !