Problèmes de couleur de liens hypertextes ! [Fermé]

Signaler
-
Messages postés
33007
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
21 juin 2021
-
Bonjour,

Je travaille actuellement sur Wordpress, avec le thème enfant de "Customizr" (en local avec WAMP). Je rencontre deux soucis avec le code CSS :
- J'aimerais que mes liens dans mes articles se mettent d'une certaine couleur, mais ils ne se mettent pas tous de cette couleur, je ne sais pas pourquoi. Pourtant j'ai mis la balise .a:link {color:#000000}
- La couleur se met aussi sur les flèches de mon slider, or je ne veux pas enlever sa couleur de base ! Même avec Firebug je ne trouve pas comment remettre la couleur de base (même avec la balise tc-slider-controls {color:#000000] ça ne marche pas).

Merci de votre aide :)

4 réponses

Messages postés
33007
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
21 juin 2021
3 571
Bonjour,

Pour commencer .. il existe différents "selecteurs" pour les liens.
Les liens cliqués ou non .. au survol, actif ..etc..
  • a:link - a normal, unvisited link
  • a:visited - a link the user has visited
  • a:hover - a link when the user mouses over it
  • a:active - a link the moment it is clicked


https://www.w3schools.com/css/css_link.asp

Ensuite,

La couleur se met aussi sur les flèches de mon slider

Sans voir ton code .. difficile de te répondre.

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Bonjour, voici le code correspondant à mon fichier style.css du thème enfant :

.navbar .nav>li>a {
padding:5px 20px;font-size:17px
}

.nav>li>a {transition:none!important}ol,ul{padding:7px}

.site-title, .site-description, .tc-header {
color:#9e7817
}

.tc-header {
border-top: 5px solid #9e7817;
}

.tc-grid .entry-header {
padding:0 8.5%
}

a:hover {
color:#9e7817;text-decoration:none
}

a:link {
color:9e7817
}

.tc-slider-controls {
position:absolute;
bottom:0;
max-height:500px;
line-height:500px;
width:10%;opacity:0;
color:#999;
z-index:10\9}

J'ai même essayé avec "!important" après le #999 (qui est la couleur que je veux garder) mais rien n'y fait.
Quelqu'un ?
Je suis désespérément seul ?
Y'a vraiment plus personne sur ce site... Sincèrement, fermez-le ou faites-en quelque chose, car CCM tombe réellement en ruines.
Messages postés
33007
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
21 juin 2021
3 571
Si si .. on est là .....

Donc : Si personne ne répond c'est que (plusieurs réponses possibles au choix) :
(et/ou) - Personne n'a envie
(et/ou) - Personne ne sait
(et/ou) - Personne n'a le temps
(et/ou) - Personne n'a compris la question


Perso .. c'est le code HTML que je voulais voir .. pas ton css ....

De plus ... pour poster du code sur le forum.. merci d'utiliser la coloration syntaxique (les balises de code).
Explications disponibles ici : https://codes-sources.commentcamarche.net/faq/10686-le-nouveau-codes-sources-comment-ca-marche#balises-code
Hum... Donc tu es là, mais tant qu'on ne hausse pas un peu le ton tu restes dans l'ombre ? Tu fais pareil dans le milieu professionnel ? Bref, merci, mais je vais plutôt aller sur le forum de WPFR, qui n'est pas infesté de gens aigris. Et pour info, si tu voulais mon code HTML tu pouvais me le préciser tout de suite, c'est jamais que 4 lettres en plus à écrire... Sur ce, ciao.
Messages postés
33007
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
21 juin 2021
3 571
Vas où tu veux ....
Moi j'ai bénévolement sur mon temps libre ..... et vu ta réflexion précédente (en plus de cette dernière...) il est clair que je ne comptais pas plus m'investir !
Bonnes recherches sur d'autres forum .... les gens qui "réclament" ou se "pleignent" à tord .. .. on n'aime pas ça de toutes façons ...

et c'est justement par ce que j'ai une vie professionnelle que je ne suis pas disponible pour "Monsieur" le pressé .....