RECHERCHEV me barre la route !

Fermé
CALLISPOOO
Messages postés
1
Date d'inscription
jeudi 27 avril 2017
Statut
Membre
Dernière intervention
27 avril 2017
- 27 avril 2017 à 12:08
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 27 avril 2017 à 13:14
Bonjour,

Après maintes essais et recherches sur les forums, pas moyen de trouver pourquoi je n'y arrive pas. Sûrement une erreur de débutante, mais voilà : toute seule je n'arriverai à rien. La situation :

J'ai une ligne de code correspondant à une marque (IK=IKEA) et je voudrais grâce à un tableau sur une autre feuille, qu'il m'affiche la marque dans la colonne à côté du code. Seulement il m'affiche à chaque fois #N/A. Quelqu'un serait pourquoi cela ne marche pas ? (cf photo)

Merci d'avance, ça bloque tout mon travail !

PS: La photo du tableau de code n'est qu'une infime partie, JD est plus bas (ordre alphabétique).

3 réponses

Mike-31
Messages postés
17957
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 mai 2022
4 947
Modifié le 27 avril 2017 à 12:36
Bonjour,

=RECHERCHEV(A5;'NOM CONSTRUCTEUR'!A2:B263;2;0)
et avec une gestion d'erreur pour éviter #N/A dans le cas ou le critère de recherche n'existe pas dans la base ou est écrite différemment
=SIERREUR(RECHERCHEV(A5;'NOM CONSTRUCTEUR'!A2:B263;2;0);"")

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
27 avril 2017 à 12:31
Bonjour
d'une part la photo a disparu?
d'autre part elle ne suffira probablement pas à résoudre le problème
si vous pouvez déposez un fichier modèle ici!
https://mon-partage.fr
et revenez coller le lien créé sur le site
en attendant, essayez de vérifier si vos données recherchées sont bien conforme, comme suit:
  • copier dans la base de données, la cellule où se trouve ele code que vous allez chercher
  • coller cette copie dans la cellule que vus utilisez pour rechercher

et voyez si le #N/A est toujours affiché
  • si la formule répond, c'est que votre valeur cherchée n'est pas écrite de la même façon que dans la base de données.
  • sinon, c'est que votre adresse n'est pas correcte dans la formule. rappel: la valeur cherchée doit être dans la 1° colonne de la plage indiquée.


à vous lire
crdlmnt


0
thev
Messages postés
1770
Date d'inscription
lundi 7 avril 2008
Statut
Membre
Dernière intervention
11 novembre 2021
663
Modifié le 27 avril 2017 à 13:07
Bonjour,

Vérifiez si les chaînes de caractères sont bien identiques et en particulier, s'il n' y a pas de différences suite à un espace inséré devant ou après la chaîne.
Pour un premier test, modifier votre formule comme suit :
=RECHERCHEV(SUPPRESPACE(A5);'NOM CONSTRUCTEUR'!A$2:B$263;1;FAUX)
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
27 avril 2017 à 13:14
juste pour mon info, ça n'arrangera pas la formule
quel intérêt d'aller chercher une valeur dans la 1° colonne de A:B pour ressortir la valeur... de la 1° colonne?
crdlmnt
0