Anniversaire sous excel

Fermé
Signaler
Messages postés
1
Date d'inscription
mardi 4 avril 2017
Statut
Membre
Dernière intervention
4 avril 2017
-
Messages postés
26394
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2022
-
Bonjour à tous,

J'ai cherché partout mais je ne trouve aucune réponse qui correspond à mon cas.
En effet, toutes les formules avec la fonction "aujourd'hui" ne conviennent pas.

Mon cas :
Sur une feuille excel, j'ai un fichier anniversaire :
Colonne A : Nom de la personne
Colonne B : Date de naissance au format JJ/MM/AAA

Sur une autre feuille :
A1 : 01/01/2017
A2 : 02/01/2017
A3 : 03/01/2017 ....

Dans la colonne B, j'aimerais avoir la liste des personnes dont c'est l'anniversaire à cette date.
Si rien n'existe pour faire une liste au cas où il y est plusieurs anniversaires un même jour, je peux mettre une colonne C, D...

Merci d'avance pour vos lumières.

2 réponses

Messages postés
2107
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
19 février 2021
496
Peut être en VBA, parcourir la colonne Anniversaire en vérifiant le jour et le mois et tenir un comptage.

[PaTaTe]
0
Messages postés
26394
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2022
6 182
Bonjour

essayez avec cette formule, si votre base est en feuil1! et votre édition en feuil2
en B1 de feuil2

=SIERREUR(INDEX(Feuil1!$A$1:$A$100;PETITE.VALEUR(SI(feuil1!$B$1:$B$100=$A1;LIGNE($A$1:$A$100));COLONNE(A$1)));"")

à tirer vers la droite pour couvrir le nombre de résultat et vers le bas pour changement de date

attention:
  • cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées

(elle s'affiche automatiquement entre accolades dans la barre de formule)
  • respectez bien les positions des signes $


crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0