Extraire NOM dans NOM Prénom ou Prénom NOM

Résolu/Fermé
camcam64
Messages postés
2
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
31 mars 2017
- 31 mars 2017 à 12:18
camcam64
Messages postés
2
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
31 mars 2017
- 31 mars 2017 à 15:18
Bonjour,

J'ai un fichier excel dans lequel, dans une même cellule, j'ai NOM Prénom ou Prénom NOM. J'aurais besoin d'avoir le NOM en premier, ou dans une autre cellule. Le but étant de pouvoir les fusionner avec un autre fichier où le nom est bien séparé du prénom et supprimer les doublons.
J'ai trouvé un sujet avec une fonction personnalisée qui sépare extrait les minuscules ou les majuscules mais la première lettre du prénom étant en majuscule, je n'ai pas obtenu l'effet souhaité !!

Est ce que quelqu'un aurait une idée ?
J'ai pensé inclure dans la fonction que j'ai testé, le fait qu'elle ne s'applique que lorsqu'il y a au moins 2 majuscules consécutives dans le mot. Mais je ne sais pas faire...

ci dessous le copier/coller de la fonction que j'ai testé

Public Function majuscules(zone)
Dim sel As Object
Dim i As Integer
Application.Volatile
For Each sel In zone
For i = 1 To Len(sel)
If Asc(Mid(sel, i, 1)) > 64 And Asc(Mid(sel, i, 1)) < 91 Then
majuscules = majuscules & Mid(sel, i, 1)
End If
Next i
Next sel
End Function

Merci beaucoup

1 réponse

via55
Messages postés
13880
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 septembre 2022
2 490
31 mars 2017 à 14:00
Bonjour camcam

Sans VBA simplement par formules :

Avec par exemple le nom/prénom séparés par un seul espace en A2, en B2 la formule pour extraire le nom : =SI(CODE(STXT($A2;2;1))<97;GAUCHE($A2;TROUVE(" ";$A2)-1);DROITE($A2;NBCAR($A2)-TROUVE(" ";$A2)))
et en C2 la formule pour extraire le prénom : =SI(CODE(STXT($A2;2;1))>=97;GAUCHE($A2;TROUVE(" ";$A2)-1);DROITE($A2;NBCAR($A2)-TROUVE(" ";$A2)))

Cdlmnt
Via

1
camcam64
Messages postés
2
Date d'inscription
vendredi 31 mars 2017
Statut
Membre
Dernière intervention
31 mars 2017

31 mars 2017 à 15:18
Super,
Vraiment merci beaucoup :))
0