Ne pas prendre en compte certaines cases dans un calcul [Résolu/Fermé]

Signaler
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
-
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
-
Bonjour,

J'ai créé un fichier EXCEL qui répertorie toutes les personnes qui suivent une formation. Je calcule pour chaque formation, le pourcentage de personnes qui l'ont suivies. Mais quand certaines personnes quittent le groupe, je les gardes dans mon fichier (pour avoir une trace) en affichant au bout de la ligne "A quitté le groupe".
Or les personnes parties sont toujours prises en compte dans le calcul de pourcentage de suivi. Comment faire pour les conserver dans le fichier sans les prendre en compte dans le calcul ??

Je vous remercie d'avance

Emilight

A voir également:

2 réponses

Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
Bonjour
exemple à adapter (à partir d'Excel 2007) pour compter le nombre de personne qui ont suivi une formation
les noms en A
le type de formation en B
information "a quitté le groupe" en C

=NB.SI.ENS(B:B;"type de formation";C:C;"<>a quitté le groupe")

ou s'il n'y a pas de tyep, de formation:

=NB.SI.ENS(A:A;"<>";C:C;"<>a quitté le groupe")

crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
Je ne comprends pas trop comment adapter la formule à mon fichier sachant que c'est sous forme de tableau à double entrée. Voulez-vous un lien de mon fichier ?
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963 >
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017

déposez le ici:
https://mon-partage.fer
et revenez coller le lien donné par le site
à vous lire
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
Voici le lien d'un exemple de mon fichier
https://mon-partage.fr/f/Ofp6ARpg/
Merci à vous
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
Bien vu le fichier, mais je ne sais pas ce que vous voulez compter en éliminant les "A quitté..."
Pouvez vous préciser (colonne, plage, champ, ect...)
et résultat où?
à vous lire
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
Oui effectivement c'est plus simple. Mais la formule fonctionne partout sauf pour une colonne ?? En colonne I, ça compte la case rouge alors que ça ne devrait pas.
Savez-vous de quoi ça pourrait venir ?
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
je ne sais plus si je vais avoir assez de patience là....

Non, la case rouge n'est pas comptée, elle est déjà éliminée par le début de la formule, par la condition > aujourd'hui (puisqu'elle est le 12/9/2015)
vous trouvez donc les 6 de l'ancienne formule qui compte toutes les lignes sauf la case rouge, moins 2 calculées de la colonne C qui affiche "A quitté.." soit résultat 4

quel est le résultat que vous voudriez avoir en I en fait (si jamais vous le savez?!)
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
Normalement le résultat doit être 5 car la seule personne dont la formation est valide, elle a quitté le groupe. Elle ne devrait donc pas être compté dans le calcul.
Mais sinon laissez tomber, vous m'avez déjà beaucoup aidé et je vous en remercie!
Messages postés
26076
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 juin 2021
5 963
dernier recours après je ne sais plus comprendre
en E

=NBVAL($B$4:$B$10)-SOMMEPROD(($C$4:$C$10<>"")*((E4:E10<AUJOURDHUI())+(E4:E10="")))-SOMMEPROD(($C$4:$C$10="")*(E4:E10<AUJOURDHUI()))

bonne chance
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
Cette formule ne fonctionne pas! Mais je vais utiliser celle que vous m'avez donné précédemment même si elle n'enlève pas tout ce que je voudrais. C'est ce qui est le plus proche de ce que je recherche.
Je vous remercie grandement pour toutes ces propositions de réponse et merci d'avoir pris le temps et d'avoir eu la patience de me répondre

Bonne journée
Emilight