Supprimer valeur quand cellule vide

Résolu/Fermé
hyoda17 Messages postés 9 Date d'inscription jeudi 6 octobre 2016 Statut Membre Dernière intervention 20 février 2017 - 19 févr. 2017 à 15:35
 hyoda17 - 20 févr. 2017 à 21:14
Bonjour,

Voici ma formule mais je souhaiterais rajouter autre chose:
{=SIERREUR(INDEX($J$1:$J$18;PETITE.VALEUR(SI($I$1:$I$18="x";LIGNE($J$1:$J$18));LIGNE($J4)));"")}

Je souhaiterais ne pas afficher le nom que je recherche si la valeur de la cellule qui est à coté est vide.

Je m'explique le "nom" est afficher quand un "x" est une cellule et il marque des points mais
si le "xxxxx" n'a pas de point je souhaiterais qui ne s'affiche pas:


Merci pour votre aide

6 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
19 févr. 2017 à 15:49
Bonjour

avec votre image, il faut avoir beaucoup d'imagination pour vous répondre, surtout quand on ne sait pas ce qu'il y a dans la cellule "point" que" vous dites "vide"
pour le principe:

=SIERREUR(SI(cell=0;"";INDEX($J$1:$J$18;PETITE.VALEUR(SI($I$1:$I$18="x";LIGNE($J$1:$J$18));LIGNE($J4))));"")}


ou selon le cas

=SIERREUR(SI(cell="";""";INDEX.......)

en supposant que cell est la cellule qui ne contient pas de point

si ça ne va pas il faudra nous en montrer plus, surout sur les adresse


crdlmnt
0
hyoda17 Messages postés 9 Date d'inscription jeudi 6 octobre 2016 Statut Membre Dernière intervention 20 février 2017
19 févr. 2017 à 16:13
Bonjour Vaucluse,

Merci pour votre répondre, excusez moi pour ne pas assez claire:

Voila plus d'explication:

Dans la cellule vide (U10)il y a une formule:
=SIERREUR(RECHERCHEV(B7;Parallele!B8:H18;6;FAUX);"")

La cellule qui se se rapproche de celle-ci (c'est la formule que je vous ai envoyé) qui correspond a la cellule (T10) dans cette cellule il y a un nom qui s'affiche mais je ne souhaite pas qu'il s'affiche quand la cellule (U10) est vide

Merci pour votre aide

Cordialement
0
hyoda17 Messages postés 9 Date d'inscription jeudi 6 octobre 2016 Statut Membre Dernière intervention 20 février 2017
19 févr. 2017 à 16:27
Re bonjour Vaucluse

Voici le tableau complet

Les personnes qui ont un "x" ont des point supplémentaire les autres non
car ils ne sont a la "//" alors il n'y a que 3 personnes qui bénéficie de points
mais le nom de la 4ème personne s'affiche alors qu'il na pas de point, voila
le problème de ma formule.

Merci d'avance
0
eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 7 141
19 févr. 2017 à 16:49
Bonjour,

pourquoi ne pas faire un simple TCD (tableau croisé dynamique) ?
eric
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
19 févr. 2017 à 17:36
!!!votre image sans les N° de ligne ou de colonne ne permet pas de s'y retrouver. Vous parlez de T10 de U10 etc..., mais ça se situe où?
on ne sait pas d'où viennent les points, ni d'ou vient la liste à droite?
on ne sait pas où il y a des formules

bref, on ne sait pas grand chose!

voyez si vous pouvez déposer le modèle Excel sur:
https://mon-partage.fr
et revenir ici coller le lien donné par le site.
à vous lire?
0
hyoda17 Messages postés 9 Date d'inscription jeudi 6 octobre 2016 Statut Membre Dernière intervention 20 février 2017
20 févr. 2017 à 18:23
Bonjour Vaucluse

Désolé de pas avoir été assez claire, et merci pour l'attention que vous portez à mon problème.

Voici le lien pour le fichier en question.

https://mon-partage.fr/f/2PjFdMvd/

Remerciement à eriiic aussi, mais un TCD ne convient pas à mon utilisation du fichier.

Cordialement
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
20 févr. 2017 à 19:24
Re
essayez celle ci en T7, toujours en matricielle à tirer vers le bas

=SIERREUR(SI(U7="";"";INDEX($J$1:$J$18;PETITE.VALEUR(SI($I$1:$I$18="x";LIGNE($G$1:$G$18));LIGNE($G1))));"")


attention! Pour régénérer la matrice, tirer en même temps sur la hauteur utile en sélectionnant T7 et U7 ensemble

crdlmnt
0
Bonsoir Vaucluse

Merci pour votre solution. Ca marche très bien.
Vous êtes mon sauveur et bravo pour votre
Experience sur Excel.

Bonne soirée
Eric
0