Somme de données via critères similaires différentes colonnes [Résolu/Fermé]

Signaler
-
 tututu -
Bonjour,

Après tri d'une grosse base de données, je cherche à obtenir le nombre de collaborateurs sous un responsable hiérarchique donné.

La forme actuelle de ma base :

Niveau 0 Niveau 1 Niveau 2 Niveau 3 Niveau 4 Niveau 5
Paul Pierre Anne Jacques Ben
Paul Pierre Jean Etienne
Paul Pierre Jean Patrick Philippe Maxime

Question : quelle formule utiliser pour compter le nombre de personnes différentes sous Paul ? Ou comment réorganiser le fichier pour m'en sortir ?

Merci par avance,


4 réponses

Messages postés
25464
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bonsoir
ça devrait donner 9 (sous Paul)
ce serait plus simple de ne pas répéter le même nom dans la même colonne lorsque le titre de ligne (Paul) est le même.
ainsi il n'y aurait qu'à compter les cellules remplies dans la plage "Paul"
pour éviter les doublons dans la même plage, il est possible de les mettre en surbrillance via une MFC

sinon vous pouvez essayer cette formule, si vos données à compter vont de B2 à F4 pour l'exemple:

=SOMME(SI(B2:F4<>"";1/NB.SI(B2:F4;B2:F4)))

attention, cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées.
Elle s'affiche automatiquement entre accolades dans la barre de formule

Crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Bonjour,

Merci pour cette réponse. En effet j'arrive à trouver le total unique.

Le problème c'est que je voudrais trouver la même réponse de manière systématique et à tous les niveaux.

A savoir: j'ai plusieurs "Paul" en niveau 0. Et il faudrait que j'obtienne la même réponse pour Pierre ou Jean...
Messages postés
52545
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
14 413
Si j'ai bien compris, on doit trouver 9 (et pas 12) dans ton exemple ?
C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Bonjour,

Merci pour cette réponse. En effet j'arrive à trouver le total unique.

Le problème c'est que je voudrais trouver la même réponse de manière systématique et à tous les niveaux.

A savoir: j'ai plusieurs "Paul" en niveau 0. Et il faudrait que j'obtienne la même réponse pour Pierre ou Jean...

Merci par avance,
Messages postés
25464
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bonjour
alors ça va être plus compliqué
voyez ici, sous réserve que votre tableau soit bien classé selon les noms en A, et les toutes les oignes aient un nom en A
(et toujours en matricielle)
https://mon-partage.fr/f/ro1i97Ra/
revenez si besoin pour adaptation, (c'est un peu complexe), mais avec plus d'info sur vos données

Note: vu le poids de ces formule et bien que le fichier proposé comporte une formule sur chaque ligne, il est préférable de la copier / coller seulement en ligne avec le 1° nom de chaque liste.
Dans ce cas, la 1° conditon n'est plus utile.

crdlmnt
Bonjour,

Merci pour ce retour.

Au finish et pris par le temps je me suis débrouillé plus simplement..

Sur un nouvel onglet j'ai repris la colonne avec l'identifiant de chaque collaborateur puis ajouté des colonnes N0 N-1 N-X

Pour chaque collaborateur et chaque colonne : =NB.SI(Colonne N0 de la base;identifiant)

Puis somme de toutes les colonnes -1 (pour enlever le manager) ce qui me donne le total par équipe...et pour le détail des noms retour dans la base....

Mais merci en tout cas !