Disparition Windows 10 après dual boot

Résolu/Fermé
.NeOx. Messages postés 93 Date d'inscription lundi 21 janvier 2013 Statut Membre Dernière intervention 11 juin 2022 - Modifié par .NeOx. le 5/02/2017 à 15:53
 Will92 - 29 nov. 2017 à 06:38
Bonjour à tous/toutes !

Je fais face à un petit soucis... je viens d'installer Ubuntu en dual boot avec Windows 10 et Ô surprise, lors du démarrage, le grub ne me propose pas de me lancer sur mon Windows...

Sur mon ordi j'ai 2 disques durs :
1 SSD où il y a/avait Windows 10 et où je voulais installer Ubuntu à côté
1 HDD où il y a tout les reste de mes fichiers

J'ai aussi un disque dur externe (mais lui n'a rien à voir dans l'histoire)

Pour installer Ubuntu, j'ai dû créer 3 partitions. Une sur mon SSD pour "/" et "/home" + une sur mon HDD pour le "swap".

J'ai malheureusement dû faire une bêtise quelque part... :/

J'ai réalisé un boot-info si ça peut aider : https://paste2.org/hV7dJXNx

PS: je ne sais pas si c'est lié ou pas, mais avant de me lancer dans l'installation j'ai appris que mon Windows 10 était en bios hérité (legacy) et pas en UEFI... ce qui est étrange car je me suis renseigné et il paraîtrait que legacy n'est plus utilisé depuis Windows 10. D'autant plus que j'ai installé moi même Windows 10 sur cet ordi que j'ai eu début décembre dernier.
SI quelqu'un aurait quelques explications de plus à me fournir, je suis preneur :D

PPS : J'ai accès à une clé bootable Windows 10 si besoin ainsi qu'à une clé Ubuntu

Merci de votre patience :)



.Neox.
La paix est le temps où l'on dit des bêtises, la guerre le temps où on les paie.
A voir également:

3 réponses

Bonjour,
Essaie d'abord ceci :
Ouvre le terminal dans Ubuntu tape la commande suivante :
sudo update-grub

Reboote et dis-nous si ton Windows apparaît au menu maintenant.

Et si ça fonctionne toujours pas
réinstallation de grub :
sudo grub-install /dev /sda
sudo update-grub
.
Ton pc boote bien sur le disque sda ?

Autre possibilité : réparateur de démarrage de boot-repair.
4
J'arrive pas à éditer la réponse, correction :
C'est
sudo grub-install /dev/sda
(sans espace)
0
.NeOx. Messages postés 93 Date d'inscription lundi 21 janvier 2013 Statut Membre Dernière intervention 11 juin 2022 3 > jns55
5 févr. 2017 à 19:17
En fait j'ai pu accéder à mon PC et... ça a fonctionné ! Merci beaucoup :)
Un simple "sudo update-grub" et le tour est joué !

Encore merci & bonne soirée !
0
.NeOx. Messages postés 93 Date d'inscription lundi 21 janvier 2013 Statut Membre Dernière intervention 11 juin 2022 3
5 févr. 2017 à 18:21
Bonsoir ! Merci pour la réponse !

Je n'ai malheureusement plus accès à l'ordinateur en question pour ce soir. J'essayerai tout ça demain et je reviendrai ici pour vous tenir au courant de l'avancement de la situation :)
0
Merci bcp mon frere, tu me sauve la vie vrt
0
jeannets Messages postés 24075 Date d'inscription dimanche 9 septembre 2007 Statut Contributeur Dernière intervention 4 décembre 2022 6 174
5 févr. 2017 à 16:11
Bonjour,

Disons que tu as la chance d'etre en Legacy, ça te permettra d'avoir le dual boot entre Linux et Windows sans trop de difficulés... en UEFI, c'est l'horreur.

L'erreur que tu as fait, c'est d'installer Grub2 pour ton dualBoot et il a écraser le démarrage de windows 10 "bootmgr"... mais ton Windows 10 n'est pas disparu, il n'y a que le démarrage qui ne marche pas.

Pour réparer ça, tu as le choix:

1° garder ton Grub2 et d'y ajouter une ligne de démarrage vers Windows

2° Réparer le démarrage de windows et y inclure le démarrage de ton Ubuntu..

Ton histoire est très courante.

Il faut savoir que Windows 10 en dualBoot commence par démarrer Windows... Présente son menu de choix... et si on choisi Linux, il reboot le PC pour ensuite aller sur Linux... C'est un peu long; de plus, si le démarrage de windows ne marche pas... on ne peut même pas aller sous Linux en solution de secours...

Ajoutons que sur certains cas (???) on perd l'activation de windows, il faut refaire l'installation et l'activation, j'ai le cas chez Moi sur un PC et pas sur un autre, je n'ai jamais trouvé l'explication.
2
.NeOx. Messages postés 93 Date d'inscription lundi 21 janvier 2013 Statut Membre Dernière intervention 11 juin 2022 3
5 févr. 2017 à 16:22
Hello !

Merci beaucoup pour ta réponse Jeannets !

Je comprend un peu mieux mon problème maintenant. Je pense utiliser la solution la plus simple. Est-ce que tu aurais quelques conseils de plus à me donner pour m'aider ?
0
jeannets Messages postés 24075 Date d'inscription dimanche 9 septembre 2007 Statut Contributeur Dernière intervention 4 décembre 2022 6 174
5 févr. 2017 à 19:07
Je crois deviner ce que tu veux..?? pouvoir démarrer l'un ou l'autre, sans etre esclave de l'autre...??

Donc il est préférable de réparer Grub... Il te démarre bien Linux... Donc il faut le completer en y ajoutant le démarrage de Windows...

Fais ce que dis @jns55, dans ton Ubuntu

Voici des indications --- Approximatives.

menuentry "Microsoft Windows 10 BIOS-MBR" {
insmod part_msdos
insmod ntfs
insmod search_fs_uuid
insmod ntldr
search --no-floppy --fs-uuid --set root='hd0,msdos1'
#drivemap -s (hd0) (hd2,msdos1)
ntldr /bootmgr
}


en tout cas, c'est "bootmgr" qui démarre windows 10

Il faut aussi parcourir les forum Linux Ubuntu
1
.NeOx. Messages postés 93 Date d'inscription lundi 21 janvier 2013 Statut Membre Dernière intervention 11 juin 2022 3
6 févr. 2017 à 23:07
Nickel ! Merci beaucoup :D
0