Connexion VNC par un tunel SSH

Fermé
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 - Modifié par thierryR51 le 5/02/2017 à 19:07
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 - 21 avril 2017 à 14:46
Bonjour,
Voila ce qui m'amène:
Je voudrais faire un script que je déclencherais par une connexion externe en SSH. Celui-ci démarrerait un seveur VNC qui écouterait sur le tunel SSH. A la fin de l'utilisation, je voudrais que le script éteigne le serveur VNC.

Je ne pars pas de zéro.
Ma connexion SSH fonctionne entre mon PC (linux mageia) et ma RaspberryPi2 (linux rasbian).
Je suis en mode console et il me manque le pilotage graphique de ma framboise. Je voudrais établir dans mon tunnel ma connexion VNC.
Sur le Raspy, j'ai installé des trucs, en suivant ce tuto: https://www.hugedomains.com/domain_profile.cfm?d=the-raspberry&e=com
Sur le client j'ai installé vncviewer et il démarre sans problème.
Mais la connexion ne se fait pas , pour cause de passwd invalide.
J'ai encore des réglages à faire, mais je me prends la tête avec ça.
Je ne sais pas quel passwd mettre. J'en ai essayé plein (tous) mais aucun ne fonctionne.

En ce qui concerne le script, comme j'utilise des clés, je n'ai pas de passwd.
Est ce que sur le client:
ssh -L 9999:localhost:5901 user@pc-distant

suffit. Mais après comment connecter vncviewer à ce tunel?

Pour bien comprendre est ce que le server sur la raspy écoute tous les client entrant ? ou seulement en sortie de tunnel ? Comment savoir ?

Vous avez remarqué, je suis un peu perdu. J'ai la tête comme une pastèque. Merci de votre écoute.

Chercheur en améliorations.

[url]
A voir également:

14 réponses

barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
5 févr. 2017 à 22:30
Comment est réglé ton pare-feu ? Poste tes règles.
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 22:53
T'as même pas configuré ton pare-feu ?!

Je te suggère d'installer ufw, beaucoup plus simple à gérer qu'iptables.

Pour installer UFW :
sudo apt-get install ufw


Pour activer UFW :
sudo ufw enable


Pour lister les règles UFW:
sudo ufw status verbose
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
5 févr. 2017 à 19:32
Bonjour,

Pour bien comprendre est ce que le server sur la raspy écoute tous les client entrant ? ou seulement en sortie de tunnel ?
==>> un serveur écoute un port, donc oui il est à l'affût de toutes connexions sur le dit port, qu'elles viennent du tunnel ou pas

Mais après comment connecter vncviewer à ce tunel?

==>> dans "vncviewer" il faudra indiquer localhost:9999 pour emprunter le tunnel
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
Modifié par thierryR51 le 5/02/2017 à 22:20
Merci pour ton aide barnabe0057. Voilà quelques résultats:

 ssh -L 9999:localhost:5901 thierry@isabelle
Last login: Sun Feb 5 20:48:29 2017 from 5.202.154.77.rev.sfr.net
thierry@raspberrypi ~ $


Ca marche.

vncserver :1

You will require a password to access your desktops.

Password:
Warning: password truncated to the length of 8.
Verify:
Would you like to enter a view-only password (y/n)? n

New 'X' desktop is raspberrypi:1

Creating default startup script /home/thierry/.vnc/xstartup
Starting applications specified in /home/thierry/.vnc/xstartup
Log file is /home/thierry/.vnc/raspberrypi:1.log


J'ai mis un passwd

Mais si je mets dans mon vncviewer: localhost:9999 j'obtiens ceci sur ma console

thierry@raspberrypi ~ $ channel 3: open failed: connect failed: Connection refused


En rentrant le même passwd j'obtiens la connexion. MAis pourquoi, j'ai galéré autant ?????
Merci de ton aide.
Chercheur en améliorations.

[url]

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
5 févr. 2017 à 22:45
Ben là, c'est la colle. J'ai limité les accès SSH uniquement par clé. J'ai donné l'accès SSH à 1 seul groupe. (Clients limites) Quant au firewall, je ne sais même pas comment il fonctionne. Il doit être configurer de base.....
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
5 févr. 2017 à 22:56
J'ai un petit souci avec ufw et ma connexion SSH
sudo ufw enable
Command may disrupt existing ssh connections. Proceed with operation (y|n)? n
Aborted


barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 22:58
oui normal, il faudra juste te reconnecter (ssh -L 9999:localhost:5901 thierry@isabelle)
0
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
5 févr. 2017 à 23:01
Je pensais perdre la liaison mais en fait non..... Tant mieux.
 sudo ufw enable
Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
Firewall is active and enabled on system startup


Je procède à la suite.
sudo ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing)
New profiles: skip


Là, je ne vois pas à quoi ça sert .....
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 23:04
Par défaut le pare-feu filtre les connexions entrantes, et autorise toutes les connexions sortantes, du classique quoi.

La journalisation est activée.
0
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
5 févr. 2017 à 23:04
Si je fais
 sudo ufw deny all


et
sudo ufw allow 22


Je casse tout ?
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
5 févr. 2017 à 23:10
oui à ne pas faire, tu vas tout couper si tu fais
sudo ufw deny all
0
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8 > barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024
5 févr. 2017 à 23:22
Ben non pour 2 raisons.
1- Ca ne fonctionne pas.
2- il faut
sudo ufw reload
pour la commande soit prise en compte.
0
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
5 févr. 2017 à 23:22
Oui heureusement
0
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 23:07
Ensuite il faut créer une règle pour SSH, si ton réseau local est en 192.168.1.0/24 :

sudo ufw allow in from 192.168.1.0/24 to any port 22

Ensuite il faut recharger la config pour prendre en compte la nouvelle règle:
sudo ufw reload
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
Modifié par thierryR51 le 5/02/2017 à 23:09
OK j'essaie.

Mauvais depart
sudo ufw deny all
ERROR: Bad port
0
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
5 févr. 2017 à 23:29
C'est dingue tous les ports qui sont ouverts. Il suffit de faire
 cat /etc/services | less

et t'es servi.
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 23:46
Ce n'est pas la liste des ports ouverts.

Pour voir tous les ports ouverts :
netstat -an | less
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 23:47
Pour voir les connexions SSH uniquement :
netstat -n | grep -w "22"
0
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
5 févr. 2017 à 23:53
Il n'y a que 2 ports ouvert avec SSH mais beaucoup d'autres que je ne connais pas. J’hésite à tout fermer.
barnabe0057 Messages postés 14450 Date d'inscription lundi 2 mars 2009 Statut Contributeur Dernière intervention 15 juin 2024 4 912
Modifié par barnabe0057 le 5/02/2017 à 23:56
Ne fais pas de bêtises à moins d'être sûr de ce que tu fais.

Je peux voir tes règles ufw ?
sudo ufw status numbered
0
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
22 mars 2017 à 17:32
Désolé de cette longue interruption. La carte SD m'a lâché, et j'ai du la recommander et tout réinstaller. Ce n'est encore opérationnelle. Je reviens très vite.
thierryR51 Messages postés 139 Date d'inscription dimanche 5 juillet 2015 Statut Membre Dernière intervention 22 juin 2021 8
21 avril 2017 à 14:46
Me revoila......
J'ai réussi à 100% ma connexion d'un debian vers mageia. Mais pas l'inverse.
Je constate que des l'instant où une connexion SSH est établie avec un PC il n'est pas dure d'y prendre la main. SSH peut démarrer/stopper le server VNC etc......
Il n'y a pas besoin d'ouvrir les port VNC si la liaison se fait à travers SSH.
J'utilise le client vinagre ( avec un peu d'huile) pour me connecter. Quand on se cogne au firewall on a un écran noir un moment. Dans la connexion mageia -> debian, le ssh ne passe pas: mot de passe refusé. Il va me falloir creuser le sshd-config. Je reviens.