Calculer un pourcentage en ignorant si champs vide

[Résolu/Fermé]
Signaler
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017
-
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017
-
Bonjour,

Je n'arrive pas a calculer un pourcentage de façon automatique en sachant que si une cellule est vide il faut l'ignorer. Du coup je n'ai pas une somme de base sur laquelle me baser.

Sur l'image ci dessous les % que j attend ligne 15 avec trois scénarios.


En espérant de l'aide et surtout d 'avoir été suffisamment précise.

Merci par avance

1 réponse

Messages postés
3295
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 septembre 2021
467
Bonjour,
"En espérant de l'aide et surtout d 'avoir été suffisamment précise.
"


Non !
pourquoi 100% dans la colonne B et 73% dans la colonne D ??

Crdmt
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017
>
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021

Une dernière chose si possible :(

Peut on intégrer à la formule une indication afin de transformer les resultats " ##### " (dans le cas de colonnes non complétées) en " #N/A " et ainsi ne pas fausser mon graphique ?



Merci, merci, merci par avance
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061 >
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017

Pourquoi des #N/A???, c'est anormal
si affichage d'erreur:
=SIERREUR(SOMME(A1:A6)/(NB.SI(A1:A6;">0")*3);"")
à partir de Excel 2007 seulement
vous pouvez mettre entre les derniers guillemets l'info texte qui pourrait vous convenir
Applicable à partir de Excel 2007 seulement, pour avant, revenez
crdlmnt
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017
>
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021

Franchement MERCI !!! Tout est en ordre
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017
>
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021

Desolée, le problème qui se pose maintenant :

Je n'ai plus de ### (remplacé par "vide") dans mon fichier excel = parfait

Cela dit mon graphique traduit le "vide" par un 0 ce qui fausse mon graphique :( ayant résolu cet échange je ne peux plus attacher de PJ pour exemple
Messages postés
20
Date d'inscription
dimanche 5 février 2017
Statut
Membre
Dernière intervention
11 avril 2017

C'est parfait !!!

Merci bcp !