Calcul par groupe d'âge

Fermé
Signaler
-
 Morrison391 -
Bonjour,

Dans ma feuille de calcul j'ai une colonne "Date de naissance" et une autre "Âge" dans laquelle j'ai une formule pour le calcul automatique. Dans une troisième cellule, j'aimerais savoir combien j'ai de personne de moins de 10 ans par exemple.

3 réponses

Messages postés
50796
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
30 janvier 2021
7 641
0
Messages postés
23
Date d'inscription
vendredi 15 janvier 2010
Statut
Membre
Dernière intervention
7 novembre 2017

Salut,
je vous propose la formule suivante si les âges se trouve en D par exemple:
=sommeprod((D2:D800<10)*(1))
Cela doit bien fonctionner. Ne mettez pas dans cette colonne 10 ans mais 10
0
Votre formule fonctionne parfaitement, mais j'avais oublié une information importante, dans cette liste j'ai des dossiers qui sont fermés et qui ne doivent pas être comptés. Donc par exemple : Colonne A = date de naissance, Colonne B = âge obtenue par un calcul, Colonne C = dossier fermé (cellule avec inscription "Fermé" ou vide si toujours ouvert). J'ai essayé ceci : =SI(ESTVIDE(C1:C50);SOMMEPROD(B1:B50<=10)*(1))
mais ça ne fonctionne pas, j'ai un message d'erreur.
Merci beaucoup pour votre aide!
0