Formule max avec conditions multiples [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
dimanche 29 janvier 2017
Statut
Membre
Dernière intervention
9 juillet 2017
-
Messages postés
7
Date d'inscription
dimanche 29 janvier 2017
Statut
Membre
Dernière intervention
9 juillet 2017
-
Bonjour,

Mike-31 m'a bien aidé dans "Formule max avec condition non vide "
Maintenant j'en veux encore;) en ajoutant une colonne (Date réception) comme critère avec résultat "non recu"
Ci dessous l'exemple (je ne sais pas comment joindre un fichier!)

Date reception Date acceptation
201 26/08/2017 27/09/2017
201 01/10/2016 01/01/2017
201 01/10/2016
201 01/11/2016 10/12/2016
207
207
213 31/12/2015 10/11/2016
218 10/06/2016 10/12/2016
218 01/02/2017
218 10/09/2016 10/09/2016

Résultat souhaité:

201 En cours
207 Non recu
213 10/11/2016
218 En cours
222 00/01/1900
458 00/01/1900
201 En cours

Bonne journée à tous

2 réponses

Messages postés
17230
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 septembre 2020
4 245
Re,

comme cela, premier critère en cellule G2 et première formule en H2

=SI(SOMMEPROD(($B$2:$B$20="")*($A$2:$A$20=G2))>0;"Non reçu";SI(SOMMEPROD(($C$2:$C$20="")*($A$2:$A$20=G2))>0;"En cours";SOMMEPROD(MAX(($B$2:$B$20)*($A$2:$A$20=G2)))))

mais pour éviter l'affichage 00/01/1900 correspondant à un résultat nul je complèterais la formule comme cela pour avoir une cellule vide à moins que tu veuilles mettre un message
=SI(ET(B2="";C2="");"";SI(SOMMEPROD(($B$2:$B$20="")*($A$2:$A$20=G2))>0;"Non reçu";SI(SOMMEPROD(($C$2:$C$20="")*($A$2:$A$20=G2))>0;"En cours";SOMMEPROD(MAX(($B$2:$B$20)*($A$2:$A$20=G2))))))

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Messages postés
7
Date d'inscription
dimanche 29 janvier 2017
Statut
Membre
Dernière intervention
9 juillet 2017

Re
Rapide
Efficace
t'es un CHEF!!

Un grand merci, grâce à toi j'ai découvert le sommeprod qui est surpuissant (j'étais limité avec le bon vieux recherchev)
J’espère que tu auras d'autres occasions de m'aider = m'apprendre

Au plaisir