Besoin d'une formule en fonction de deux paramètres

Résolu/Fermé
Captain_Harlock Messages postés 4 Date d'inscription mardi 19 avril 2016 Statut Membre Dernière intervention 16 janvier 2017 - 16 janv. 2017 à 12:08
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 16 janv. 2017 à 14:16
Bonjour,
Je voulais savoir s'il était possible de créer une formule qui, pour tous les produits du tableau partageant le même id, vérifierait la valeur "Prix" de chacun d'eux, et renverrait "1" pour le produit au plus bas et "0" pour les autres.
Ce n'est peut-être pas très clair, du coup j'ai joint une image.


Merci d'avance !

PS : Je sais que ce n'est pas vraiment dans les normes de traiter plusieurs produits avec un même id, mais c'est hélas ainsi que la gestion des attributs fonctionne, avec Prestashop.

3 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 308
16 janv. 2017 à 12:30
Bonjour
Matricielle en E2 à tirer sur la hauteur utile:

=SI(D2=MIN(SI($A$2:$A$100=A2;$D$2:$D$100));1;0)

Attention: formule matricielle, pour l'entrer:
maintenir enfoncées en même temps les touches ctrl et shif et taper sur "enter"
(elle va s'afficher automatiquement entre accolades dans la barre de formule)
respecter bien les signes $ aux bons endroits.
Ce type de formule étant assez lourd, limitez bien la hauteur du champ (ici de ligne 2 à 100) au strict minimum selon vos données.
crdlmnt




0
Captain_Harlock Messages postés 4 Date d'inscription mardi 19 avril 2016 Statut Membre Dernière intervention 16 janvier 2017
16 janv. 2017 à 12:40
Bonjour,
Merci pour votre aide, mais j'ai essayer sur mon tableau d'exemple et cette formule ne prends pas en compte les Id. En l'appliquant, seul le produit à 50€ a "1" se retrouve avec "1" pour Default, tous les autres ont 0.
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 308
Modifié par Vaucluse le 16/01/2017 à 12:55
Re
vous avez du oublier de lire le paragraphe "Attention".j'y ai pourtant mis du gras
Suivez les infos et vous obtiendrez ça:
https://www.cjoint.com/c/GAql1a4cE3e
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Captain_Harlock Messages postés 4 Date d'inscription mardi 19 avril 2016 Statut Membre Dernière intervention 16 janvier 2017
16 janv. 2017 à 14:06
J'avais bel et bien fait l'opération
Quoi qu'il en soit, j'ai trouver une formule fonctionnelle pour résoudre le problème. Merci tout de même pour le fichier.
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 308
16 janv. 2017 à 14:16
Il n'y a pas de quoi, tout de même
0
Mike-31 Messages postés 18178 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 janvier 2023 5 033
Modifié par Mike-31 le 16/01/2017 à 12:57
Bonjour,

Parce que tu n'as pas déclaré correctement ta formule matricielle que je te propose de compléter comme cela

=SI(A2="";"";SI(D2=MIN(SI($A$2:$A$100=A2;$D$2:$D$100));1;0))
colle la formule de l(ami Vaucluse ou cette dernière exemple en G2

une fois collé, à la place de faire Entrée pour valider ta formule il faut cliquer en même temps sur les trois touches du clavier Ctrl, Shift (c'est la touche majuscule) et Entrée
et si tu fais bien la formule se placera automatiquement entre
ces accolades {}
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
0