Recherche d'une formule avancée sur Excel

Résolu/Fermé
Mimichou28 Messages postés 9 Date d'inscription jeudi 24 novembre 2016 Statut Membre Dernière intervention 20 décembre 2016 - Modifié par Mimichou28 le 15/12/2016 à 17:22
Mimichou28 Messages postés 9 Date d'inscription jeudi 24 novembre 2016 Statut Membre Dernière intervention 20 décembre 2016 - 20 déc. 2016 à 13:56
Bonjour,

Je cherche une aide pour réaliser une formule.
Mon problème est le suivant:

Dans un premier tableau, j'ai renseigné un nombre de contrats signés dans l'année 2017, mois par mois.
Dans un second tableau, j'ai le CA généré par chaque contrat signé, mois par mois.

Dans le troisième tableau, je voudrais renseigner le CA généré par mois, à partir du mois de signature du contrat.

Est-ce que quelqu'un connaît une formule pour réaliser ce type de calcul svp?

J
A voir également:

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 287
Modifié par Vaucluse le 15/12/2016 à 17:26
Bonjour

=SOMMEPROD((MOIS(champ date)=N° du mois cherché)*(champ des montants))

ce code impose des champs limités avec des n° de ligne (pas de A:A ou B:B donc)
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Mimichou28 Messages postés 9 Date d'inscription jeudi 24 novembre 2016 Statut Membre Dernière intervention 20 décembre 2016
15 déc. 2016 à 17:36
Bonjour,

Merci beaucoup de votre aide si rapide!
Puis-je abuser et vous demander si c'est possible de me donner un exemple avec les numéros de cases de mon tableau joint svp? J'ai du mal à voir qu'est ce qui correspond à quoi dans votre formule...
De plus, pouvez-vous me dire si cette formule permet d'additionner les CA des différents contrats signés au fur et à mesure de l'année?

Merci de votre aide précieuse!
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 287
15 déc. 2016 à 17:49
Non.. jr ne comprend pas ce que vous voulez à partir du tableau un peu trop réduit!
si vous pouvez déposer un fichier avec plus d'explications ici, et peut être un exemple de la marche à appliquer et du résultat à obtenir.

https://www.cjoint.com/

et revenez ici coller le lien donné par le site

à vous lire
0
Mimichou28 Messages postés 9 Date d'inscription jeudi 24 novembre 2016 Statut Membre Dernière intervention 20 décembre 2016 > Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022
15 déc. 2016 à 17:58
Voici le lien de l'image du tableau en question: http://www.cjoint.com/c/FLpqZMaibtV

Dans le troisième tableau (celui du bas), je voudrais renseigner le CA généré par mois (2ème tableau), à partir du mois de signature du contrat (info donnée par le premier tableau).

En effet, à chaque signature de contrat, le CA généré est déterminé par le mois 1, le mois 2, le mois 3...
Par exemple, le contrat est signé en mai 2017, un CA apparaîtra donc en mai 2017 de la façon suivante:
CA mai 2017 = C27
CA juin 2017 = D27
...
CA septembre 2017 (signature d'un nouveau contrat) = G27 + C27

J'espère que c'est plus clair?
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 287 > Mimichou28 Messages postés 9 Date d'inscription jeudi 24 novembre 2016 Statut Membre Dernière intervention 20 décembre 2016
Modifié par Vaucluse le 15/12/2016 à 18:15
Toujours pas trop compris,

je tente pour que nous puissions avancer:
formule en C30 à tirer jusqu'en N30
en respectant bien la position des signes $

=SOMME.SI($C$24:C24;1;$C$27:C27)

qui vous donnera la somme évolutive des montants quand 1 est entré en ligne 24

soit selon l'image
la vlaur de D27 ern D30
la valeur de D27+H27 en H30
la valeur de D7+H7+J7 en J30

mais je ne vois pas ce que G27 viens faire la dedans!
0
Mimichou28 Messages postés 9 Date d'inscription jeudi 24 novembre 2016 Statut Membre Dernière intervention 20 décembre 2016
16 déc. 2016 à 10:25
Bonjour,

Malheureusement ce n'est toujours pas ça.
Désolée, je ne suis pas assez claire.

Le premier tableau indique quand dans l'année, les contrats sont signés. Par exemple, le "1" en case D24, indique qu'un contrat annuel a été signé en mai 2017.
Cela signifie, qu'à partir de mai 2017, l'entreprise va toucher des revenus.
Ces revenus correspondent au 2ème tableau: le CA généré, mois par mois, pendant 1 an.
Du coup, à partir de mai 2017, l'entreprise va toucher:
- en mai l'équivalent du mois 1, soit 1881€
- en juin, l'équivalent du mois 2, soit 1983€
- en juillet, l'équivalent du mois 3, soit 2540€
- etc...

A partir de septembre 2017, un nouveau contrat est signé (signalé par le "1" en case H24).
A partir de septembre 2017, le CA de l'entreprise sera donc composé de:
- le montant généré par le 1er contrat signé en mai. Nous en sommes alors au mois n°5, soit 2997€
- + le montant généré par le 2ème contrat signé en septembre. Nous sommes ici au 1er mois du contrat, soit 1881€.

Dans mon 3ème tableau, je cherche donc à ce qu'en cellule H30, le montant soit égale à 2997+1881=4878€
Et ainsi de suite...

Est-ce plus clair?
Savez-vous comment m'aider svp?
0