Combiner plusieurs fonction si dans une même cellule

Résolu/Fermé
Signaler
-
 Lucho -
Bonjour,

je vais essayer d'être clair et concis. J'aurais besoin d'aide.
J'aimerais que si ma cellule :
( 1<O16<3 alors la cellule P16 = III mais que si 4<O16<6 alors P16 = II mais que si 7<O16<9 alors P16=I )
Avec une seule condition ma cellule P16 affiche la valeur demandée mais lorsque je rajoute une nouvelle condition en mettant & entre les deux, ma cellule P16 affiche erreur !
Merci de votre aide

3 réponses

Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
98
Bonjour,

tu es sur de tes intervalles ?
Que se passe-t-il si O16=4 par exemple ?
Ou si O16 < 1 ou > 9 ?

--
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
2743
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
1 décembre 2021
1 714
Bonjour,

Voici une possibilité pour vous:
Formule a écrire en P16
=Si(et(O16>1;O16<3);"III";si(O16<6;"II";si(O16<9;"I";"Erreur de saisie")))

Avec cela ça devrait être bon.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Parfait, merci Diablo13800 !
C'est exactement ce qu'il me fallait !
Je vais maintenant pouvoir continuer mes conditions en restant sans cette même logique.

Bonne semaine
Messages postés
2743
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
1 décembre 2021
1 714
Dans le cas ou O16 peut valoir 1 ( par exemple) :
Mettez O16>=1

ça vous permettra d’éviter des erreurs malgré des chiffres cohérents:)

N’hésitez pas çà passer le sujet en résolu
Voici m'a formule finale :
=SI(ET(O16>=1;O16<=3);"III";SI(O16<=6;"II";SI(O16<=9;"I";SI(O16<=12;"S4";SI(O16<=15;"S3";SI(O16<=18;"S2";SI(O16<=24;"S1";SI(O16<1;"0";"Erreur de saisie"))))))))

Pas très élégante mais elle fonction, ou presque.
Je rencontre un unique problème au moment d'indiquer que si O16<1:"0; !
Lorsque j'affiche 0 dans m'a cellule il continue de me mettre II dans O16.
Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
98
Il faut mettre cette condition au tout début.

Donc :
=SI(O16<1; "0"; SI(ET(O16>=1;O16<=3;........))
Merci à vous pour votre aide !
CDLM