Excel - Définir le nombre de 0 devant un nombre [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
samedi 19 novembre 2016
Statut
Membre
Dernière intervention
21 novembre 2016
-
Messages postés
54031
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
10 juin 2021
-
Bonjour,

J'aimerai que si A1=3 et B1=96, B1 devienne 096 automatiquement.
De même, si A1 vaut 5, que B1 devienne 00096.

Merci d'avance.

A voir également:

4 réponses

Messages postés
32109
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
10 juin 2021
7 721
Bonjour,

Le nombre de valeurs possibles de A devant être limité, on pourrait faire une règle de mise en forme conditionnelle pour chacune de ces valeurs.

si 3 mettre un format personnalisé de la cellule = 000
si 4 mettre un format personnalisé de la cellule = 0000
si 5 mettre un format personnalisé de la cellule = 00000
...



Cdlt
        un étranger, c'est un ami qu'on n'a pas encore rencontré.
Messages postés
54031
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
10 juin 2021
16 046
Myckou, si tu nous expliques dans quel but tu poses cette question, peut-être qu'on pourra te suggérer une autre approche du problème, une autre façon d'opérer.

En attendant tu peux utiliser la
mise en forme conditionnelle
; mais au lieu de l'onglet Remplissage, habituellement choisi, c'est avec l'onglet Nombre qu'on définit le format personnalisé 000 si A1=3 ; et il faut créer, dans la même cellule B1, autant de règles de MFC qu'il y a de valeurs possibles en A1.
https://www.cjoint.com/c/FKuaABD6t4E
C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 445
Bonjour,

Tu cherches à faire un format particulier, il n'y a pas de formule pour changer le format sauf si tu le fais avec VBA.
Bonjour Mickou,

J'ai bien vu que tu voudrais ton format en B1, mais je te propose
quand même ceci, qui te sera peut-être utile :

En A1 : 3 ; en B1 : 96 ; en C1 : =TEXTE(B1;REPT("0";A1))
3 en A1 => 096 en C1 ; 5 en A1 => 00096 en C1 ; format
texte pour les résultats.

Cordialement.  😊