Copier une formule en passant de l'horizontale au verticale

Résolu/Fermé
Signaler
-
 oOo_ZiZ_oOo -
Bonjour,
Je voudrais copier la même formule verticalement mais changer la lettre de référence de la cellule sans changer le chiffre de cette cellule.
Exemple: COUNTIF(A1:A8, "x") dans la cellule J6 --> COUNTIF(B1:B8, "x") dans la cellule J7 (juste au dessous de la cellule précédente).


A voir également:

4 réponses

Messages postés
3418
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 janvier 2022
498
Bonjour,

sous une autre forme :

=NB.SI(DECALER($A$1;0;LIGNE()-6;8;1);"x")

Crdmt
1
Messages postés
18298
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 002
Bonjour, et merci de me faire découvrir la fonction DECALER (OFFSET)!
0
Messages postés
55418
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
17 226
Attention, yg_be !

La personne qui intervient depuis le post #6 n'est pas Zzzz, l'initiateur de la discussion, ni DjiDji, qui a proposé la formule ...
1
Messages postés
18298
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 002
merci Raymond
0
Messages postés
18298
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 002
Je propose cette formule, qui change la référence de colonne en fonction de la ligne où se trouve la formule.

=COUNTIF(INDIRECT("R1C"&ROW()-5&":R8C"&ROW()-5;FALSE);"x")
0
Messages postés
18298
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 002
DjiDji59430 et moi t'avons chacun proposé une formule que tu peux insérer dans une cellule, puis copier vers le bas, afin d'obtenir le résultat que tu souhaites.
Dis-nous si cela fonctionne.
0
Messages postés
55418
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2022
17 226
... surtout avec cet agréable mélange de fonctions en anglais et en français,
de virgules et de points-virgules ...
0
Messages postés
3
Date d'inscription
dimanche 13 novembre 2016
Statut
Membre
Dernière intervention
14 novembre 2016

La formule que vous avez proposé m'indique une erreur
0
Messages postés
18298
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 002
et ceci ?
=COUNTIF(OFFSET($A$1,0,ROW()-6,8,1),"x")
0
Messages postés
3
Date d'inscription
dimanche 13 novembre 2016
Statut
Membre
Dernière intervention
14 novembre 2016

Que signifie le -6,8,1?
0
Messages postés
18298
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
1 002
cela fonctionne?
0