Masquer une cellule [Résolu/Fermé]

Signaler
-
Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
-
Bonjour,
je suis en train de crée une feuille de devis et nous proposons des prix par 50/100/150/200/..... je souhaiterais faire en sorte de masquer des cellules si la taille du lot n'ai pas demandé ex ici avec 50 pièces

j'ai ca
50 100 150 200
12,00 € 10,67 € 10,22 € 10,00€
12,51 € 11,17 € 10,73 € 10,51 €

10,0% 5,0%

13,76 € 11,73 € 10,73 € 10,51 €



100 150 200

#DIV/0! 10,67 € 10,22 € 10,00
#DIV/0! 11,17 € 10,73 € 10,51 €

10,0% 5,0%

#DIV/0! 11,73 € 10,73 € 10,51 €


peut on faire en sorte que mes #div/0 deviennent invisibles.

j'espère avoir été assez clair c'est un peux du chinois l'info pour moi.
merci pour vos reponses

2 réponses

Messages postés
2297
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
6 août 2020
1 142
Bonjour,

Utiliser un Si pour vérifie ça :)

=Si(A1=0; " " ; *le reste de votre formule*)

A adapter suivant votre tableau bien sur
du coup ca serai plutôt
- si A1 super à 0 alors la formule s'applique "100/A1"
si A1 =0 alors la formule ne s'applique pas " case reste blanche"
Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
5 393
Bonjour
peut être simplement à partir d'Excel 2007:
=SIERREUR(formule);"")
crdlmnt
00
du coup ca serai plutôt
- si A1 super à 0 alors la formule s'applique "100/A1"
si A1 =0 alors la formule ne s'applique pas " case reste blanche"
Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
5 393
SIERREUR fonctionne dans tous les cas pour éliminer le #DIV0
mais à partir d'Excel 2007 seulement
donb:
=SIERREUR(100/A1);"") devrait faire l'affaire
mais avant 2007 vous pouvez écrire pour éliminer les 0 et les vides éventuels en A:
=SI(OU(A1="";A1=0);"";100/A1)
crdlmnt
merci beaucoup pour vos réponses du coup j'ai utilisée la formule suivante:
=SI(ESTVIDE(C30);""; 100/C30)
Messages postés
25210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 août 2020
5 393 > petit0mel
c 'est bien si ça fonctionne, mais ça renvoie encore une erreur si jamais C30 est égal à 0 parfois. Ce qui à priori, n'est pas votre cas.
Bonne route
crdlmnt