Formule et tri

Résolu/Fermé
Annie - 28 sept. 2016 à 21:29
 Annie - 29 sept. 2016 à 01:04
Bonjour,

Je travaille avec Excel depuis plusieurs années et aujourd'hui j'ai besoin d'aide.

Voilà mon problème :

Sur la feuille #1, j'ai une liste d'item avec le prix unitaire.

Sur la feuille #2, j'ai des produits d'une recette et les quantités.

Exemple, je veux savoir si je veux savoir le prix que ça me coûte dans ma recette, je prends ma quantité multiplié par le prix unitaire dans la feuille #1. Jusque là tout va bien ma formule fonctionne.

Mais dès que je fais un tri A-Z ou que je rajoute une ligne, mon calcul devient incorrect, car il ne prends plus la bonne ligne, car ce qu'il avait exemple sur la ligne 2 n'est plus sur la même ligne avec le tri.

Il me faudrait donc une formule qui va vraiment chercher la bonne ligne: Exemple : le prix de la crème sur dans la feuille #1?

Merci à l'avance pour toute votre temps et aide.

Bonne journée,


2 réponses

Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 522
28 sept. 2016 à 22:32
Bonjour,

Tu peux utiliser la fonction RECHERCHEV.
Avec les couples Produit-Prix dans la plage Feuil1!$A$2:$B$100,
le produit en Feuil2!A2,
la formule en Feuil2!B2 sera :
=RECHERCHEV(A2;Feuil1!$A$2:$B$100;2;FAUX)

A+
0
Merci beaucoup Gyrus!! :)
0