Tableur avec double formule [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mercredi 21 septembre 2016
Statut
Membre
Dernière intervention
22 septembre 2016
-
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
-
Bonjour,

j'ai besoin de votre aide. j'ecris d'un ipad ou je n'ai pas mon doc excel, du coup j'explique d'abord a quoi ressemble mon tableur et comment sont placées mes données :
feuille1:
Colonne A: il y aura des dates de naissance
colonne B:ce pour quoi je demande votre aide

feuill2:
A1 : 01/01/1950
B1 : 31/12/1950
C1 : Groupe 1
A2 : 01/01/1951
B2 : 31/12/1951
C2 : group 3
et ainsi de suite jusqu'à l'année 1980


voila ce que je recherche a faire :
une formule dans la colonne B de la feuille 1 qui recherche la date de naissance ecrite dans cellue A1 de feuille 1 parmi les colonnes AetB de feuille 2.
ue fois que la date de naissance a ete située correctement dans quelle fourchette de date elle se situe, faire apparaitre das A1 de feuille 1 le numero du groupe

pas facile a expliquer desolée
merci beaucoup pour votre aide


1 réponse

Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 903
Bonjour
si, en colonne A kls dates de début d'années sont classée's en ordre croissant, une formule de recherche devrait suffire (la colonne B devient inutile)

=SIERREUR(RECHERCHE;Feuil!2;A:C;3);"")

quin ressort la valeur de feuil2!C sur la ligne ou A est directement inférieur à la date en A1

le code SIERREUR en complément évite l'affichage #N/A en cas de date non trouvée; Il ne fonctionne qu'à partir d'Excel 2007
si votre Excel est antérieur, vous pouvez écrire:

SI(ESTERREUR(RECHERCHEV(A1;Feuil!2;A:C;3);"";RECHERCHEV(A1;Feuil!2;A:C;3))

oui bien sur dans tous les cas:
=RECHERCHEV(A1;Feuil!2;A:C;3)

si vous admettez l'affichage éventuel d'erreur.

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
3
Date d'inscription
mercredi 21 septembre 2016
Statut
Membre
Dernière intervention
22 septembre 2016

merci ca marche!!! merciii!
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 903
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt