Fonction si

Fermé
Philippe - 17 sept. 2016 à 10:15
Raymond PENTIER Messages postés 56699 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 1 octobre 2022 - 18 sept. 2016 à 15:58
Bonjour,
Je n'arrive pas à résoudre ce problème

a1=9 b1=12 c1=si(a1&b2<12,5;b1-a1;(b1-a1)-0,75)

Le résultat donne 2,25 alors que cela devrait donner 3

Je ne vois pas ou est le problème

A l'avance merci


3 réponses

Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 534
17 sept. 2016 à 10:31
Bonjour,

Essaie avec :
=SI(ET(A1<12,5;B1<12,5);B1-A1;(B1-A1)-0,75)

A+
0
Utilisateur anonyme
18 sept. 2016 à 04:13
Bonjour Philippe,

En A1 : 9 ; et A1 est inférieur à 12,5 ; en B1 : 12 ; et B1 est aussi
inférieur à 12,5 ; donc le résultat de 2,25 que tu as cru faux est
bien correct !  😉  Je te propose cette formule :

=B1-A1-0,75*(ET(A1<12,5;B1<12,5))

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  😊


PS : Bonjour à Gyrus en passant.
 
0
Raymond PENTIER Messages postés 56699 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 1 octobre 2022 17 178
18 sept. 2016 à 15:58
Bonjour Philippe.

Quand tu écris =SI(A1&B1<12,5;B1-A1;(B1-A1)-0,75)
tu demandes à Excel de fabriquer un texte en accolant le contenu de A1 et celui de B1, ce qui donne dans ton exemple le mot "912".
Ce mot n'ayant aucune valeur numérique, le test A1&B1<12,5 ne fonctionne pas et affiche FAUX ...
0