Copier/coller en changeant nom feuille [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
samedi 10 septembre 2016
Statut
Membre
Dernière intervention
15 septembre 2019
-
Messages postés
26000
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 mai 2021
-
Bonjour,

J'ai plusieurs feuilles excel (pas plusieurs onglets), nommées S 01, S 02, S 03.... et une autre feuille nommée "CUMUL"

Dans ma feuille cumul, je veux faire un tableau avec sur la ligne 1 la somme de 21 cellules de la feuille s 01, sur la ligne 2 la somme de 21 cellules de la feuille 2 ... (les cellules concernées sont les mêmes sur chaque feuille)

Comment faire un copier coller de ma formule sur chaque ligne en changeant juste le nom de ma feuille et en conservant toujours les mêmes cellules ?

1 réponse

Messages postés
26000
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 mai 2021
5 909
Bonjour
Si vos feuilles s'appellent S 01 S02 S03 ect...et que vbous voulez cumuler A1:A21 de chacune de ces feuilles (à adapter)

en A1 de la feuille cumul:

=SOMME(INDIRECT("'S "&TEXTE(LIGNE(A1);"00")&"'!A1:A21"))

attention à tous les signes

et pour éviter un affichage d'erreur en tirant la formule si la feuille n'existe pas encore:

=SIERREUR(SOMME(INDIRECT("'S "&TEXTE(LIGNE(A1);"00")&"'!A1:A21"));"")

applicable sur Excel à partir de 2007.Vous pouvez placer un texte d'information entre les derniers guillemets si besoin.

crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci