Celulles avec une formule + liste déroulante

Fermé
Signaler
-
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
-
Bonjour,

Je souhaite ajouter des listes déroulantes à des cellules qui contiennent des formules.
J'ai des données qui se complètent automatiquement suivant la sélection d'une base de données (colonne code).

Je souhaite ajouter des listes déroulantes pour effectuer des modifications semi-automatiquement.

Avec ceci vous devriez y voir plus clair : http://www.cjoint.com/c/FIhmUUFtZqW

Merci d'avance.

5 réponses

Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 853
Bonjour,

pourquoi ne pas utiliser cette formule en C3 et l'incrémenter vers le bas
=SIERREUR(RECHERCHEV(A3;$A$17:$E$22;3;0);"")
Sur toute la base de données il est préférable de passer par index equiv plutot que recherchev, sinon le fichier serait trop lourd.
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 853
Re,

a bon et pourquoi plus lourd, tu peux m'expliquer !

tu peux simplifier ta formule en nommant tes plages exemple $A$17:$E$22 nommée List ta formule quelque soit l'onglet sur lequel tu vas l'utiliser devient

=SIERREUR(RECHERCHEV(A3;List;3;0);"")

si tu veux quelque chose plus technique, tu actives ta cellule C3 et Formules/Noms définis/Gestionnaire des noms/Nouveau/donne un nom à ton Champ exemple Rech (pour rechercher) et tu colles la formule
=SIERREUR(RECHERCHEV(A3;$A$17:$E$22;3;0);"")
et si tu as nommé ta matrice
=SIERREUR(RECHERCHEV(A3;List;3;0);"")

en C3 tu fais référence au Champ =Rech
et tu incrémentes vers le bas
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Quand je modifie la liste déroulante, la valeur est remplacée mais la formule a été écrasée.
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 853
Re,

mais c'est normal dans une cellule tu ne peux avoir qu'une formule ou une liste de validation pas les deux et pas deux formules ou il faut les imbriquer

=SIERREUR(INDEX(C$17:C$22;EQUIV($A3;$A$17:$A$22));"")
ou =SIERREUR(RECHERCHEV(A3;$A$17:$E$22;3;0);"")
ne font que rechercher l'équivalence Code/Sexe d’où mes propositions alors explique exactement ce que tu veux faire exemple en C3

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Je voudrais que même lorsque je selectionne dans ma liste déroulante, la formule soit activée et non supprimée.
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 853
Re,

Alors ça c'est impossible, explique ce que tu veux afficher en C3 dans ta liste de validation en plus de la formule déjà présente dans cette cellule
J'ai réussi à garder ma formule dans mes cellules et y affecter ma listes déroulantes (suivant les listes) mais je bloque pour les modifis au niveau de la colonne Code.

Cf ligne 6 : http://www.cjoint.com/c/FIhoKMDRfRW

Si je modifie la liste déroulante, il faut que je trouve une formule en colonne Code pour que le code se modifie.
Messages postés
17697
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 853
Re,

quel intérêt, une fois que tu utilises la liste de validation ta formule est effacée, autant traiter directement l'affichage avec une de mes formules