Extraire d'une cellule une date

[Résolu/Fermé]
Signaler
-
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,

Voici mon exemple:

Cellule A1 : LH/KF 29/06/2016
Cellule A2 : W500 lot 015
Cellule A3 : vide
Cellule A4 : LH/KF 29/06/2016
Cellule A5 : W500 lot 016
Cellule A6 : vide
Cellule A7: vide
Cellule A8 : LH/KF 01/07/2016
Cellule A9 : w500 lot 356
Cellule A10 : vide

Je souhaiterais que dans toute la colonne A, excel m'extrait la date et me la mets dans une colonne à part.
J'ai essayer donnée-->convertir-->...
mais j’obtiens beaucoup d'information des autres lignes, que je ne souhaite pas.
En sachant que le nombre de case "vide" entre chaque date est tout à fait aléatoire.
Je peux avoir 1 case vide ou 2 ou plus sans ordre logique.
Si quelqu'un sait comment faire, je suis preneuse.
Merci.

1 réponse

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 058
Bonjour
compte tenu des informations que vous donnez:
sur toute la hauteur:

=SIERREUR(DROITE(A1;10)*1:"")
dans des cellules au format date
valable à partir d'Excel 2007 seulement sinon:
=SI(ESTERREUR(DROITE(A1;10)*1):"";DROITE(A1;10)*1)
crdlmnt

Ps1:s'il risque d'y avoir, des blancs en tête ou fin de l'extraction:
=SIERREUR(SUPPRESPACE(DROITE(A1;10))*1:"")

Ps2 vous pouvez ensuite faire un copier collage spécial de la colonne pour supprimer les formules en gardant les dates


La qualité de la réponse dépend surtout de la clarté de la question, merci!
impeccable.
Merci :)
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 058
Pas de quoi, je passe le sujet en résolu
Bonne route
crdlmnt