Extraire expression/chaîne de caractères

[Résolu/Fermé]
Signaler
Messages postés
276
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
1 décembre 2018
-
Messages postés
276
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
1 décembre 2018
-
Bonjour,

J'ai converti un PDF en fichier excel.

A partir de celui-ci, je souhaiterais extraire l'expression "doc. vaudoise" suivi des 30 caractères qui suivent (qui sont à chaque fois différents)

Est-possible ? Existe-t-il une formule à appliquer ?

Merci d'avance !

Bien à vous,

J.




1 réponse

Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Bonjour ,

petite question , comment est constitué le texte ?
Chaque ligne de texte correspond à une ligne du tableur ou est ce que toutes les lignes sont contenues dans la premiere cellule ?

Si chaque ligne contient une phrase, pour récupérer ce que vous souhaitez :

=STXT(A1;TROUVE("doc. Vaudoise";A1);NBCAR("doc. Vaudoise")+30)

Cordialement,
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
276
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
1 décembre 2018
29 >
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020

C'est fait, seulement il n'affiche que "introuvable"...il faut double cliquer sur la formule à dans la cellule précise afin qu'il y aie une résultat. C'est très étrange !
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66 >
Messages postés
276
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
1 décembre 2018

Vérifie les paramètres de calcul :

Fichier > Options > Formules > Calcul du classeur : Automatique.
Par moment ça saute.
Messages postés
276
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
1 décembre 2018
29 >
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020

Et ça fonctionne !

Merci Fahora, et merci Vaucluse !

Vous m'avez enlevé un sacré sapin du pied !
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
J'ai simplement utilisé nbcar pour éviter de compter le nombre de caractère dans doc.vaudoise

Cette formule fonctionne chez moi ,
=SIERREUR(STXT(A1;CHERCHE("doc. Vaudoise";A1);NBCAR("doc. Vaudoise")+30);"Introuvable")
Messages postés
276
Date d'inscription
vendredi 3 août 2007
Statut
Membre
Dernière intervention
1 décembre 2018
29
La formule marche également ! Merci Fahora :)