Ne plus prendre en compte une cellule en fonction de son contenu

[Résolu/Fermé]
Signaler
-
 Serocelot -
Bonjour à tous,

J'aurais besoin d'un petit coup de main...

J'ai utilisé une formule me permettant de compter les doublons de mon tableau :
=SI(B3<>"";SI(NB.SI($B$3:B3;B3)=1;1;0);"")

Je voudrais faire en sorte que si jamais je remplis ma colonne C, la ligne dont la colonne C est remplie ne soit plus prise en compte pour le compte de mes doublons.

Je ne sais pas si je suis claire ou si cela est seulement possible ;)

Un petit exemple

Colonne A Colonne B Colonne C
1 Pomme
1 Poire
0 Banane Mangée
0 Poire
1 Banane

En gros, comme la banane a été mangée, elle n'est plus à prendre en compte, et donc c'est la banane inscrite ensuite qui passe en 1.

J'espère être claire !

Merci encore pour votre aide !

1 réponse

Messages postés
26182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2021
6 052
Bonjour

pas forcément tout compris, mais essayez avec:

=SI(B3<>"";SI(NB.SI.ens($B$3:B3;B3;$C$3:C3;"")=1;1;0);"")

utilisable à partir d'Excel 2007 seulement, sinon:

=SI(B3<>"";SI(SOMMEPROD(($B$3:B3=B3)*($C$3:C3=""))=1;1;"")
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
C'est génial c'est exactement ce qu'il me faut !
Merci beaucoup pour votre aide !