Pouverz vous m'aider à installer vlc sur jessie ?

Résolu/Fermé
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
- 28 août 2016 à 15:29
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
- 29 août 2016 à 03:04
Bonjour,

voilà ce que j'obtiens après un apt-get install vlc



root@debian-alain:/home/alain-bellec# apt-get install vlc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
vlc est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
vlc : Dépend: fonts-freefont-ttf mais il n'est pas installable
Dépend: vlc-nox (= 2.2.4-1~deb8u1) mais ne sera pas installé
Dépend: libgles1-mesa (>= 7.8.1) mais il n'est pas installable ou
libgles1 mais il n'est pas installable
Dépend: libgles2-mesa (>= 7.8.1) mais il n'est pas installable ou
libgles2 mais il n'est pas installable
Dépend: libsdl-image1.2 (>= 1.2.10) mais il n'est pas installable
Dépend: libva-drm1 (>= 1.1.0) mais il n'est pas installable
Dépend: libva-x11-1 (>= 1.0.3) mais il n'est pas installable
Dépend: libvlccore8 (>= 2.2.0) mais ne sera pas installé
Dépend: libvncclient0 (>= 0.9.9) mais il n'est pas installable
Dépend: libxcb-composite0 mais il n'est pas installable
Recommande: vlc-plugin-notify (= 2.2.4-1~deb8u1) mais ne sera pas installé
Recommande: vlc-plugin-samba (= 2.2.4-1~deb8u1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).



la commande apt-get install vlc-nox m'a renvoyé ceci :


root@debian-alain:/home/alain-bellec# apt-get install vlc-nox
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
vlc : Dépend: fonts-freefont-ttf mais il n'est pas installable
Dépend: libgles1-mesa (>= 7.8.1) mais il n'est pas installable ou
libgles1 mais il n'est pas installable
Dépend: libgles2-mesa (>= 7.8.1) mais il n'est pas installable ou
libgles2 mais il n'est pas installable
Dépend: libsdl-image1.2 (>= 1.2.10) mais il n'est pas installable
Dépend: libva-drm1 (>= 1.1.0) mais il n'est pas installable
Dépend: libva-x11-1 (>= 1.0.3) mais il n'est pas installable
Dépend: libvlccore8 (>= 2.2.0) mais ne sera pas installé
Dépend: libvncclient0 (>= 0.9.9) mais il n'est pas installable
Dépend: libxcb-composite0 mais il n'est pas installable
Recommande: vlc-plugin-notify (= 2.2.4-1~deb8u1) mais ne sera pas installé
Recommande: vlc-plugin-samba (= 2.2.4-1~deb8u1) mais ne sera pas installé
vlc-nox : Dépend: libbasicusageenvironment0 mais il n'est pas installable
Dépend: libcddb2 mais il n'est pas installable
Dépend: libcrystalhd3 (>= 1:0.0~git20110715.fdd2f19) mais il n'est pas installable
Dépend: libdvbpsi9 (>= 1.1.0) mais il n'est pas installable
Dépend: libebml4 mais ne sera pas installé
Dépend: libgroupsock1 mais il n'est pas installable
Dépend: libiso9660-8 (>= 0.83) mais il n'est pas installable
Dépend: liblivemedia23 mais il n'est pas installable
Dépend: libmatroska6 mais ne sera pas installé
Dépend: libpostproc52 (>= 5:0.git20120217~) mais il n'est pas installable
Dépend: libresid-builder0c2a mais il n'est pas installable
Dépend: libshine3 (>= 3.1.0) mais il n'est pas installable
Dépend: libsidplay2 mais il n'est pas installable
Dépend: libupnp6 (>= 1:1.6.19) mais il n'est pas installable
Dépend: libusageenvironment1 mais il n'est pas installable
Dépend: libvcdinfo0 (>= 0.7.21) mais il n'est pas installable
Dépend: libvlc5 (>= 2.1.0) mais ne sera pas installé
Dépend: libvlccore8 (>= 2.2.0) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@debian-alain:/home/alain-bellec#


je ne sais plus quoi faire ....

apt-get -f install donne


root@debian-alain:/home/alain-bellec# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libavahi-common-dev libcupsfilters-dev libieee1284-3-dev libmysqlclient18
libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-opengl
libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-svg
libqt4-test libqt4-xmlpatterns libqtassistantclient4 libqtwebkit4
libsane-extras-dev libsensors4-dev libtiffxx5 libusb-1.0-0-dev
libusb-1.0-doc libv4l-dev libv4l2rds0 libwrap0-dev mysql-common python-qt4
python-sip
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
vlc
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 4 787 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 146540 fichiers et répertoires déjà installés.)
Suppression de vlc (2.2.4-1~deb8u1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6) ...
root@debian-alain:/home/alain-bellec#


n'y aurait il pas , comme dans ubuntu , des commandes pour configurer jessie compatible avec tout le multimedia ?
etc...

7 réponses

luckydu43
Messages postés
3462
Date d'inscription
vendredi 9 janvier 2015
Statut
Membre
Dernière intervention
23 mars 2022
799
28 août 2016 à 15:43
Bonjour !

Peut-être que je me trompe, je ne connais l'univers Linux que de loin ;-)
Chaque ligne "Dépend: fonts-freefont-ttf mais il n'est pas installable" devrait avoir son agt-get install ;-)

En somme, installez TOUTES les dépendances pour pouvoir faire fonctionner vlc. C'est long, mais après tout : c'est mon avis et je me trompe peut-être ;-)

Voili...

Bonne journée

Luc
0
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
5
28 août 2016 à 16:08
déjà essayé (pour l'imprimante) , cela ne mène à rien . la solution est ailleurs .

j'ai essayé avec les backports , voilà le résultat :


root@debian-alain:/home/alain-bellec# apt-get -t jessie-backports install "package"
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet package
root@debian-alain:/home/alain-bellec# apt-get -t jessie-backports install vlc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
vlc : Dépend: fonts-freefont-ttf mais il n'est pas installable
Dépend: vlc-nox (= 2.2.4-1~deb8u1) mais ne sera pas installé
Dépend: libgles1-mesa (>= 7.8.1) mais ne sera pas installé ou
libgles1
Dépend: libgles2-mesa (>= 7.8.1) mais ne sera pas installé ou
libgles2
Dépend: libsdl-image1.2 (>= 1.2.10) mais il n'est pas installable
Dépend: libva-drm1 (>= 1.1.0) mais il n'est pas installable
Dépend: libva-x11-1 (>= 1.0.3) mais il n'est pas installable
Dépend: libvlccore8 (>= 2.2.0) mais ne sera pas installé
Dépend: libvncclient0 (>= 0.9.9) mais il n'est pas installable
Dépend: libxcb-composite0 mais il n'est pas installable
Recommande: vlc-plugin-notify (= 2.2.4-1~deb8u1) mais ne sera pas installé
Recommande: vlc-plugin-samba (= 2.2.4-1~deb8u1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@debian-alain:/home/alain-bellec#
0
Bonjour,
Je pense que tu as installé un logiciel qui a cassé les dépendances.
Ce logiciel a installé des paquets d'une version qui n'est pas compatible avec les dépendances de vlc. Tant que tu n'auras pas désinstallé ce logiciel, tu seras bloqué par ce problème.
Essaie de te souvenir quels logiciels tu as installé et regarde les dépendances dans synaptic.
Ça risque d'être fastidieux pour trouver le fautif.
0
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
5
28 août 2016 à 17:22
pour avoir cherché avec d'autre commandes , je peux vous dire que , tout simplement , nombre de dépendances de vlc n'existent pas sous jessie .

pareil pour hplip Hewlett Packard .

jessie est , apparemment , tellement en avance ,
que beaucoup de programmes ne sont pas encore prêts .
0
"jessie est , apparemment , tellement en avance ,
que beaucoup de programmes ne sont pas encore prêts .
"


Allons, ne dis pas de sottises... jessie est la version stable de Debian, elle est restée très longtemps en testing avant de devenir la version officielle, elle a donc tout ce qu'il faut et tout est rôdé depuis des mois et des mois. J'ai installé vlc sur Jessie et toutes les dépendances ont été satisfaites. Mais si tu as installé un programme qui a installé des dépendances d'une version autre que la version demandée par vlc, l'installation ne peut se faire.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
5
Modifié par tyfanch le 28/08/2016 à 23:54
ben non , justement .

à part maintenant , je viens d'installer les dépendances pour I386 (jessie 32 bits)

mais ça ne change rien bien que minidlna demande libid3tag0 que j'installe depuis son deb : refus et donc refus pour minidlna
0
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
5
29 août 2016 à 00:40
je viens de faire une mise à jour de mon systeme . y avait du boulot !

j'ai pu installer plex mais pour vlc , voilà ce que ça donne :


root@debian-alain:/home/alain-bellec# apt-get install vlc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
vlc est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
vlc : Dépend: fonts-freefont-ttf mais il n'est pas installable
Dépend: vlc-nox (= 2.2.4-1~deb8u1) mais ne sera pas installé
Dépend: libgles1-mesa (>= 7.8.1) mais ne sera pas installé ou
libgles1
Dépend: libgles2-mesa (>= 7.8.1) mais ne sera pas installé ou
libgles2
Dépend: libsdl-image1.2 (>= 1.2.10) mais il n'est pas installable
Dépend: libva-drm1 (>= 1.1.0) mais il n'est pas installable
Dépend: libva-x11-1 (>= 1.0.3) mais il n'est pas installable
Dépend: libvlccore8 (>= 2.2.0) mais ne sera pas installé
Dépend: libvncclient0 (>= 0.9.9) mais il n'est pas installable
Dépend: libxcb-composite0 mais il n'est pas installable
Recommande: vlc-plugin-notify (= 2.2.4-1~deb8u1) mais ne sera pas installé
Recommande: vlc-plugin-samba (= 2.2.4-1~deb8u1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).
root@debian-alain:/home/alain-bellec#
0
tyfanch
Messages postés
83
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
1 septembre 2016
5
29 août 2016 à 03:04
j'ai relu mon post :

ligne 5 :
vlc est déjà la plus récente version disponible.

ce qui veut dire que je me casse les dents pour rien car vlc est déjà installé
par défaut , d'origine .

ben merde alors !
elle est bien bonne celle là !
0