ConvNumberLetter [Résolu/Fermé]

Signaler
-
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
-
Bonjour,

J'ai un souci avec cette macro, je l'ai téléchargée et installer dans mon fichier mais dès que je l'ouvre à nouveau (après avoir fermé et enregistré) la macro ne fonctionne plus j'ai systématiquement droit à #NOM?
Pouvez-vous m'aider SVP

9 réponses

Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Bonjour,

oui mais pour t'aider il faudrait avoir plus d'explications sur la structure du fichier, le code macro etc ...
le mieux serait d'avoir un bout de ton fichier anonymisé que tu peux joindre en suivant cette procédure
1) Clic sur ce lien https://www.cjoint.com/
2) Clic sur le bouton Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien en bas de la page
4) Au bout de quelques secondes en haut de la page en bleu souligné un lien sera généré, tu le sélectionnes et tu le copies dans une réponse
Messages postés
6
Date d'inscription
mardi 2 août 2016
Statut
Membre
Dernière intervention
3 août 2016

Bonjour,

Ci-joint le lien pour mon fichier :
https://www.cjoint.com/c/FHckYklbjCw
Merci pour ton aide. Mon souci est dans les onglets "Facture" et "Factures Aquagym
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Re,

tu va commencer par améliorer tes formules, exemple onglet Factures en cellule H10 colle cette formule
=SIERREUR(RECHERCHEV(C23;'Liste synchro'!B2:AJ434;9;0);"")

sur ce principe modifie les formules en G11
=SIERREUR(RECHERCHEV(C23;'Liste synchro'!B2:AE428;11;0);"")
puis en G12, I12, N27, F31, F33, F35

idem onglet Factures Aquagym

ensuite en cellule D27 tu fais référence à un autre classeur, comment s'appelle t il exactement avec son extension
Messages postés
6
Date d'inscription
mardi 2 août 2016
Statut
Membre
Dernière intervention
3 août 2016

Re,
Ok pour les corrections.
Pour pouvoir convertir en lettre le montant que je recherche et qui s'inscrit en N27 dans l'onglet facture, j'ai téléchargé Convnumberletter que j'ai enregistré dans le fichier 'C:\users\v.pezet\appData\Roaming\Microsoft\Assins\Nblettre.xla
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Re,
pour cela plusieurs possibilités, regarde ce lien
http://gerard.g.pagesperso-orange.fr/logexl_05.htm#Convertir_nombres_en_lettres

si non tu peux coller un des codes de cette discussion dans un module du Visual basic (clic droit sur l'onglet/Visualiser le code/Insertion/Module)

https://forums.commentcamarche.net/forum/affich-453489-vb6-conversion-chiffres-lettres
ensuite clic dans la cellule dans laquelle tu veux la conversion, Formules/insérer une fonction/Personnalisées
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
6
Date d'inscription
mardi 2 août 2016
Statut
Membre
Dernière intervention
3 août 2016

Merci Mike pour ta recherche la page de gerard.g m'a permis de m'inspirer pour créer ma macro malheureusement mon souci n'est pas traité dans sa page.
Je vais essayer les codes donnés dans l'autre lien autrement ce n'est pas grave je ferai sans
Merci beaucoup pour ta réactivité c'est très gentil !!!!
Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
Bonjour vava348

Peut être y-a-t'il y a concordance avec la question de
Vince98800
? Je fais une réponse pour réactiver le complément NbLettres.xla

Cordialement
Messages postés
6
Date d'inscription
mardi 2 août 2016
Statut
Membre
Dernière intervention
3 août 2016

Bonjour PapyLuc51
Oui c effectivement le même problème mais malgré le code copié cela ne résout pas mon problème car dès que je ferme mon fichier il faut que je refasse toute la procédure d'activation de la macro cela ne fonctionne pas automatiquement et j'ai systématiquement cette erreur #NOM?
Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
si c'est du code proposé par Maurice dont tu parles c'est une autre manœuvre ; après avoir copier le code il faut enregistrer sous excel prenant en charge les macros et utiliser le nouveau fichier et utiliser la formule =chiffrelettre(cellule contenant les chiffres)

Avant que Maurice propose ce code je proposais cette
réponse
pour simplifier ce que décrit Vince98800 dans sa question.
Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
Je reviens

Je n'avais pas vue que tu avais joint un exemplaire de ton fichier. Comme c'est déjà un classeur prenant en charge les macros il te suffit d'enregistrer la nouvelle macro et d'utiliser la nouvelle formule proposée dans la section personnalisées, par contre il faut effacer le mot euro de la cellule G27 car il sera déjà inscrit dans le résultat en lettres

Cordialement
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Re,

télécharge ton fichier ensuite enregistre le sous avec l'extension XLSM
https://www.cjoint.com/c/FHcpdOeStMj
Merci Mile 31
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Re,

es ce que ton problème est résolu !
Messages postés
6
Date d'inscription
mardi 2 août 2016
Statut
Membre
Dernière intervention
3 août 2016

Bonjour Mike-31,

Je confirmerai dans la journée si mon problème est résolu ; Merci à toi
Messages postés
6
Date d'inscription
mardi 2 août 2016
Statut
Membre
Dernière intervention
3 août 2016

Merci beaucoup Mike ça fonctionne super bien !!!!!
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Re,

alors passe le statut de la discussion en résolu ou confirme le moi que je le fasse pour toi