Combinaison fonction "si" "et" et "recherche v"

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
vendredi 29 juillet 2016
Statut
Membre
Dernière intervention
29 juillet 2016
-
Messages postés
3
Date d'inscription
vendredi 29 juillet 2016
Statut
Membre
Dernière intervention
29 juillet 2016
-
Bonjour,

Je galère avec ma formule, je ne sais pas ce qui cloche.

Je veux obtenir ceci:

Si quand tu cherches dans la colonne B tu trouves C2 et si quand tu cherches dans la colonne C tu trouves 1 alors dans ce cas tu me sommes uniquement les cellules de la colonne O des lignes correspondant aux deux critères.

J'ai essayé celle-ci:

=SI(ET(RECHERCHEV(1;'Commandes SAP facturées'!$C$2:$U$75;1;FAUX);RECHERCHEV('Tableau de synthèse'!C4;'Commandes SAP facturées'!$B$2:$U$75;1;FAUX));SOMME.SI('Commandes SAP facturées'!$B$2:$B$75;'Tableau de synthèse'!C4;'Commandes SAP facturées'!$O$2:$O$75);"")

Mais elle ne me somme que selon le premier critère.

Le but de la manœuvre est de mensualiser les coûts en fonction des natures comptables (critères 1 et 2).

Auriez vous une solution?

Merci d'avance.

2 réponses

Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Bonjour ,

La solution réside certainement dans la somme.si.ens qui te permet de faire la somme de tes colonnes avec plusieurs conditions.

Pour qu'on puisse adapter une vraie formule, le plus simple est que tu nous transmette ton fichier.
(un exemple à suivre pour ce faire)

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...


N'hesite pas à modifier ton fichier initial pour nous transmettre le moins d'informations confidentielles possibles.

Cordialement,
Messages postés
3
Date d'inscription
vendredi 29 juillet 2016
Statut
Membre
Dernière intervention
29 juillet 2016

Merci Fahora, c'était tout simple et ça marche!
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Peux tu nous donner la solution que tu as trouvé ? De cette façon, ça servirait peut être à d'autre ?
Messages postés
3
Date d'inscription
vendredi 29 juillet 2016
Statut
Membre
Dernière intervention
29 juillet 2016

la solution:
=SOMME.SI.ENS('Commandes SAP facturées'!$O$2:$O$75;'Commandes SAP facturées'!$B$2:$B$75;'Tableau de synthèse'!$C$4;'Commandes SAP facturées'!$C$2:$C$75;1)