Formule excel nombre de date inf de 30 jours vs aujourdhui [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
jeudi 21 juillet 2016
Statut
Membre
Dernière intervention
22 juillet 2016
-
Messages postés
9
Date d'inscription
jeudi 21 juillet 2016
Statut
Membre
Dernière intervention
22 juillet 2016
-
Bonjour,

Je n'arrive pas à créer une formule qui consiste a me donner le nombre de date inférieur ou a égal a 30 jours par rapport a la date du jour.
Je m'explique j'ai en colonne AA une suite de date et je souhaite connaitre le nombre de date inférieur a 30 jours par rapport a la date du jour.

Merci par avance car je rame

Bonne journée
A voir également:

1 réponse

Messages postés
23892
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021
6 663
Bonjour,

Si tu n'as pas de dates postérieures à aujourd'hui :
=NB.SI(A:A;">="&AUJOURDHUI()-30)

sinon :
=NB.SI.ENS(A:A;">="&AUJOURDHUI()-30;A:A;"<="&(AUJOURDHUI()))

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
23892
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021
6 663
quelle version d'excel ? 2003 ?
Dans ce cas :
=SOMMEPROD(($A$2:$A$10=D2)*($B$2:$B$10>=AUJOURDHUI()-30))


PS: nom en D2
Messages postés
9
Date d'inscription
jeudi 21 juillet 2016
Statut
Membre
Dernière intervention
22 juillet 2016

Eric merci pour ta patience
Tu as réussi c'est super je vais pouvoir avancer.

Bonne fin de journée

PS ; tu es vraiment un AS
Messages postés
9
Date d'inscription
jeudi 21 juillet 2016
Statut
Membre
Dernière intervention
22 juillet 2016

Eric

Je continue mon travail est j'ai une formule qui marche dans un sens mais pas dans l'autre :
=SOMMEPROD(($J$4:$J$100>=AUJOURDHUI())*1)
mais par contre quand je souhaite savoir le nombre de date INFERIEURE a aujourd'hui j inverse le symbole et la ca ne fonctionne pas ca compte seulement le nombre de cellule de J4 a J100 sans tenir compte de mon critère.

Ma formule est la suivante :
=SOMMEPROD(($J$4:$J$100<=AUJOURDHUI())*1)

Suis je passée a coté de quelque chose ?

Merci et bonne journée
Messages postés
23892
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021
6 663
Bonjour,

essaie de prendre l'habitude de déposer un classeur en situation et réduit au minimum pour la question.
Là on ne peut que faire des hypothèses et parfois elle sont nombreuses.
Une cellule vide est une date 01/01/1900, je suppose donc que tu en as :
=SOMMEPROD(($J$4:$J$100<=AUJOURDHUI())*($J$4:$J$100<>"")*1)

D'autre part sommeprod est une fonction matricielle (bien que de validation normale) et donc très gourmande.
Il faut donc essayer d'utiliser que la plage nécessaire. Avec un nom dynamique si besoin.
eric
Messages postés
9
Date d'inscription
jeudi 21 juillet 2016
Statut
Membre
Dernière intervention
22 juillet 2016
>
Messages postés
23892
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021

Excuses moi je ne suis pas habitué de ce site.

J'en prend note pour de futurs besoins.

Ta formule fonctionne Merci